Jump to content


Photo

Need Help Fault Finding On Ps3 Drive


  • Please log in to reply
4 replies to this topic

#1 uk_dan2k

uk_dan2k

    X-S Senior Member

  • Validating
  • PipPip
  • 296 posts
  • Location:united kingdom - england
  • Interests:games, movies, music, beer...Hummm.....beer.
  • Xbox Version:none
  • 360 version:v3.0 (falcon)

Posted 17 January 2011 - 10:22 PM

hi all,

i've ended up with a 2nd hand ps3 (already wondering if its a door stop).
anyway tried loading a game, a dvd and a music cd all do the same thing.

1st you have to jam 1/2 of the into the drive before it pulls it inside.
2nd after the disc is in the correct position, the laser moves to the center of the disc (or next to spindle).
from what i can tell i can't see any light emitting from the laser.
3rd the clock on the ps3 spins and spins but nothing ever shows up for playing game / film / music.

wasn't sure on the part thats causing the problem so i brought another drive that comes with all except logic board which i just get from my knackered drive.
swapped it all over and got the same as above, seems to try load put never gets to the spinning up stage and also the seller said that the drive and laser unit is fully tested working.

I have noticed the plastic clip for holding the blue-ray ribbon cable to the motherboard is broken off on the motherboard side and so i'm using some tape to hold it down for now.

my question is, would the ribbon cable not attached properly cause the clock to just keep spinning and never spin up the drive.
or is it a fault with the logic board being knackered or possible not the original one? (although i read somewhere that incorrect logic boards the clocks never spin at all).

Edited by uk_dan2k, 17 January 2011 - 10:24 PM.


#2 uk_dan2k

uk_dan2k

    X-S Senior Member

  • Validating
  • PipPip
  • 296 posts
  • Location:united kingdom - england
  • Interests:games, movies, music, beer...Hummm.....beer.
  • Xbox Version:none
  • 360 version:v3.0 (falcon)

Posted 18 January 2011 - 12:21 AM

quick update, the drive is now accepting discs and spinning the discs up along with the correct lasers been used, i can clearly see red for dvds and blue for games.

the discs remain spinning untill i press eject, but nothin is showin up on the ps3 menu and nothing is auto booting.

any ideas on the cause? i'll keep re-applyin the big ribbon cable maybe its not in properly but can this problem also be caused by having a fried or not the original drive logic unit ?

Edited by uk_dan2k, 18 January 2011 - 12:21 AM.


#3 uk_dan2k

uk_dan2k

    X-S Senior Member

  • Validating
  • PipPip
  • 296 posts
  • Location:united kingdom - england
  • Interests:games, movies, music, beer...Hummm.....beer.
  • Xbox Version:none
  • 360 version:v3.0 (falcon)

Posted 18 January 2011 - 03:43 AM

wierd i was able to download latest update 2.50 to 2.55 but after downloading a demo it wont play, stuck on a black screen.



#4 wildwild

wildwild

    X-S Member

  • Members
  • Pip
  • 148 posts

Posted 30 January 2011 - 05:52 AM

Hi,

The good news are:
1. Spinning clock means it has the correct Blu Ray board,
2. Disc spins up means that the laser and Blu Ray boards are OK.

I think your problem is the broken black plastic clip. If you still have the clip then re-install it and tape it down to keep it in place. Otherwise, you need to cut a thin plastic shim (from plastic milk bottle or something) to the correct width and jam it in between the ribbon cable and connector (there is a thread somewhere in this forum).

You might want to do a complete system restore.


Good luck

smile.gif smile.gif smile.gif



#5 Mr Spoon87

Mr Spoon87

    X-S Enthusiast

  • Members
  • 5 posts

Posted 12 March 2011 - 12:26 PM

It could also be a software issue have you tried reintalling the drivers using the restore menu?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users