Jump to content


Photo

Is Now A Good/silly Time To Jump Onboard?


  • Please log in to reply
1 reply to this topic

#1 bob808

bob808

    X-S Enthusiast

  • Members
  • 10 posts

Posted 30 April 2011 - 12:16 PM


I am looking at getting a ps3 slim and lobbing on CFW... I know that right now I would need to ensure the system comes with no newer than 3.55, and I wont be able to play most new games on it due to the 3.6 issues.

With the iminent new FW coming out with the relaunch of PSN, there is surely going to be more security rolled in... as no-one has yet been able to make a CFW of 3.6, should we be concerned that the good days are coming to an end, or are you hopeful of a 3.7 (or whatever they call it) CFW coming out in the near future?

Thanks

bob

#2 asoftlad

asoftlad

    X-S Enthusiast

  • Members
  • 24 posts

Posted 30 April 2011 - 04:15 PM

QUOTE(bob808 @ Apr 30 2011, 12:16 PM) View Post

I am looking at getting a ps3 slim and lobbing on CFW... I know that right now I would need to ensure the system comes with no newer than 3.55, and I wont be able to play most new games on it due to the 3.6 issues.

With the iminent new FW coming out with the relaunch of PSN, there is surely going to be more security rolled in... as no-one has yet been able to make a CFW of 3.6, should we be concerned that the good days are coming to an end, or are you hopeful of a 3.7 (or whatever they call it) CFW coming out in the near future?

Thanks

bob


Bob,
The problem with newer games is a change of keys for >=3.6, at the moment only Matteliuh has claimed that he has found the keys for 3.6 and doesnt intend to release them. No other hacker/group has confirmed publicly that they are working on this. Sony's aggresive tactics of persuing hackers through the courts has had the desired effect of scaring other devs/hackers from releasing anything.

If backups is your goal, you'll have to accept its a perpetual cat and mouse game and you'll have to accept that newer games/firmware will introduce additional/revised security challenges. However, this doesn't change the fact that if you went CFW you could still enjoy the compatible <=3.55 back catalogue of games and homebrew available.

Don't hold your breathe for a CFW 3.6 in the near future is the underlying message and also be mindful that there's abit of a lull as the scene has slumped recently, so in regards to timing it doesn't really matter as nothing has been announced that will change the current situation.








0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users