Jump to content


Photo

Error 202 Programming Block


  • Please log in to reply
4 replies to this topic

#1 HERiTAGE

HERiTAGE

    X-S Enthusiast

  • Members
  • 29 posts

Posted 08 May 2011 - 10:12 PM

Hello!
I'm in need of some help regarding my zephyr JTAG.

I extracted the kv and config file from the nand (not the whole nand) and from there, i made a new zephyr nand from a clean one (used jtag tool to download the clean nand) and used that one as base to do the FB version using jtag tool.

The thing is, my nand chip is damaged or something and i always get a programming error at blocks 118,119 and 11A. Even when i try to erase the nand it gives me that error on the exact same blocks, over and over again.

I've learned about remapping the blocks and all that, but the processes always implies me having to analyse my supposedly damaged nand file in order to find the block locations and remap them, but like i said, i rebuilt the nand with the kv and config file from a clean file, so i don't have that information showing up on the tools because nothing is really wrong with the file, but instead, the problem is with the chip.

As a consequence of this, when i flash through xellous (xellous loads since the affected blocks are after the end of the xellous location on the nand), the flashing status returns those errors on 118, 119 and 11A and just maps them to the end of the nand 3FF, i guess, or something.
When i try to boot i always get e71 and 1 light.

I've tried a lot of stuff, even more than once.
I tried flashing old dashboard versions, new ones, without the config file, etc, etc.

I don't know exactly how can i fix. I've done several jtags before and never encountered this before.

Thanks in advance!

Edited by HERiTAGE, 08 May 2011 - 11:11 PM.


#2 HERiTAGE

HERiTAGE

    X-S Enthusiast

  • Members
  • 29 posts

Posted 10 May 2011 - 02:53 PM

Didn't have a lot of help... sad.gif

Well, i fixed it anyway and i'm leaving the info here for someone else with the same problem. Sorry if it's something widely known but i never encountered a problem like this and the info out there was mostly about remapping badblocks from a badly extracted file, which was not the case.
First thing to take note is, xellous sometimes remaps blocks wrong, so don't use it to auto remap.

Anyway, i had 3 bad blocks on the nand chip but a perfectly rebuilt nand file with all the information on the correct blocks. When i went to flash it always returned me an error writing blocks 118, 119 and 11A, so because of that the console couldn't boot and just gave an e71 error.
xellous automatically remaps the blocks but it didn't work for me at all. It did show the remapping, but the console wouldn't boot.

I decided to remap them manually with nandpro.
So basically i needed to use another part of the chip to store the information that was assigned to those faulty blocks.
That part should be the last part of the chip, which is precisely reserved for bad blocks.

This is how i did it:

Reading the badblocks from the nand file:
nandpro xbr.bin: -r16 block1.bin 118 1
nandpro xbr.bin: -r16 block2.bin 119 1
nandpro xbr.bin: -r16 block3.bin 11A 1

Writing the badblocks to the nand file: (notice how i go backwards from 3FF to 3FD, it's supposed to be like this)
nandpro xbr.bin: -w16 block1.bin 3FF 1
nandpro xbr.bin: -w16 block2.bin 3FE 1
nandpro xbr.bin: -w16 block3.bin 3FD 1

Just flash through xellous or lpt or whatever. This time the program won't try to write information to the bad blocks, so the flashing will just go smoothly without any remapings.
That's it! The console should be booting.

Cheers!

Edited by HERiTAGE, 10 May 2011 - 02:54 PM.


#3 tk_saturn

tk_saturn

    X-S X-perience

  • Members
  • PipPip
  • 417 posts
  • Xbox Version:unk
  • 360 version:v4.0 (jasper)

Posted 10 May 2011 - 06:56 PM

We already know, it's all in a tutorial https://docs.google....mv5h_23gw47ddgs.A tutorial which is in the same sub forum you started this topic in and is on the first page of that forum.

Edited by tk_saturn, 10 May 2011 - 06:59 PM.


#4 HERiTAGE

HERiTAGE

    X-S Enthusiast

  • Members
  • 29 posts

Posted 11 May 2011 - 02:24 AM

Great!
Now i know what you could have told me before i figured out the solution! How cool is that?

#5 krizalid

krizalid

    X-S Expert

  • Dev/Contributor
  • PipPipPip
  • 612 posts
  • Location:Mexico
  • Xbox Version:none
  • 360 version:v5.0 (360S - trinity)

Posted 12 May 2011 - 11:23 PM

You could have read tutorials prior to just looking forward to hack your console and this thread wouldn't of existed. sleeping.gif




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users