Jump to content


Photo

Surreal64 CE B5.5


  • Please log in to reply
143 replies to this topic

#91 Rage518

Rage518

    X-S Enthusiast

  • Members
  • 25 posts

Posted 11 September 2011 - 05:45 PM

@keine

If you want to hide the screens which prompt you to select plugins all you have to do is press x when a game is highlighted, next click on emulator settings, then click on hide launcher screens to make sure its set to yes. After this all you have to do is press B twice to get back to the rom menu and press A on a game and it will simply launch.

For the compatibility status you see under a games description you don't have to do anything to get that its already been set via an ini file the emulator uses to automatically determine what settings each game uses. Props to scorp316 for helping with the compatibility settings for surreal.



#92 ganjatron

ganjatron

    X-S Young Member

  • Members
  • Pip
  • 35 posts

Posted 15 September 2011 - 03:18 PM

Anybody have any luck getting GoldenEye:X to run? I'm loving playing multiplayer in Perfect Dark but since regular GoldenEye multiplayer is still not working I figure this is the only way. If it works for you, what engine and settings are you using? The ones in the ini make it bootable, but unplayable.

#93 weinerschnitzel

weinerschnitzel

    X-S Senior Member

  • Dev/Contributor
  • PipPip
  • 279 posts
  • Xbox Version:v1.0
  • 360 version:v4.0 (jasper)

Posted 16 September 2011 - 03:45 AM

GoldenEye and Perfect Dark are very resource intensive games to play on the xbox. Project64x also has a large draw in comparison to the other emulators. Unfortunately that is the only current option to play GoldenEye:X. Using a 128MB xbox, you can play multiplayer GoldenEye:X with 1 major slowdown (usually at the beginning of the first fire fight.) The game speed will pick up afterwards.

That's the best its gonna get, for the time being.

#94 ganjatron

ganjatron

    X-S Young Member

  • Members
  • Pip
  • 35 posts

Posted 16 September 2011 - 04:22 AM

Perfect Dark works great for me in 1964; not perfect, but definitely playable. For GE:X, it just doesn't detect the expansion pak and then freezes when loading a multiplayer match.

Thank you for all your hard work WS. I am super satisfied with 5.5, I just long to play goldeneye multiplayer and since the real deal is still not working, I thought this would be a good bet given that PD works well enough.

#95 montoyafan

montoyafan

    X-S Young Member

  • Members
  • Pip
  • 32 posts

Posted 27 September 2011 - 04:02 PM

Hi, should I be using the N64 rom list from the xtras released last year to match the pictures?, and where can I find the N64 xmv movies.
Thanks in advance

#96 dballs442

dballs442

    X-S X-perience

  • Members
  • PipPip
  • 456 posts
  • Location:Durango, CO
  • Interests:Sustainability, Playing music, Mountain Biking, Snowboard, Games, Micro Beer, Camping, River Sports
  • Xbox Version:v1.0
  • 360 version:unknown

Posted 27 September 2011 - 06:24 PM

How can i adjust the screen in surreal's menu? on my buddies wide screen HD TV surreal is either way to big or too small and off to the left of the screen depending on if i have 720 on in XBMC or depending on if i have the default skin or HD skin on.

#97 weinerschnitzel

weinerschnitzel

    X-S Senior Member

  • Dev/Contributor
  • PipPip
  • 279 posts
  • Xbox Version:v1.0
  • 360 version:v4.0 (jasper)

Posted 29 September 2011 - 06:43 AM

You can find the videos at EmuXtras. Links are also posted on wikidot under Wiki-Downloads. Those ads really do suck without having a username... :/

As for the launcher screen settings, its only limited to using the highest resolution available. Sorry, we are moving in a little bit of a different direction, so you won't see a new release for any more changes to the XXX GUI.


#98 stlouisrod

stlouisrod

    X-S Enthusiast

  • Members
  • 1 posts

Posted 01 December 2011 - 04:24 AM

I've tried using several different skins, but I can't get any of my xmv videos to show in the emulator front end ROM selection screen. The box art shows up fine, but the video showing is always the static.xmv one. I have all my videos named the exact same as their ROM file counterpart (except for the extension of course). I also have XMV preview enabled in the GUI settings. The media location is D:\media (the default). My videos are in the D:\media\movies folder. I've pressed Y to refresh, the screen goes black, and I hear the hard drive crunching for 5-10 seconds, but nothing changes. Am I missing something here? Thanks!

Edited by stlouisrod, 01 December 2011 - 04:44 AM.


#99 Ash123

Ash123

    X-S Member

  • Members
  • Pip
  • 74 posts

Posted 01 December 2011 - 07:36 AM

Hi. Has anybody managed to get Banjo-Tooie running yet?

I've used the automatic settings, the game starts OK but after the opening sequence when you get to play the game it freezes with the jigsaw piece in the middle of the screen.
Do I need to change any of the settings?

These are the default settings.

Emu: 1964
Video Plugin: Rice 6.1.2
Audio Plugin: Basic
RSP Plugin: High Level
Enable RSP Audio: No
Rom Paging Method: XXX
Max Video Memory: 3MB

1964
Dynarec Memory: 11MB
Paging Memory: 5MB

Project 64
Dynarec Memory: 10MB
Paging Memory: 4MB


#100 weinerschnitzel

weinerschnitzel

    X-S Senior Member

  • Dev/Contributor
  • PipPip
  • 279 posts
  • Xbox Version:v1.0
  • 360 version:v4.0 (jasper)

Posted 02 December 2011 - 05:51 AM

You'll get the most reliable settings with JttL and Rice 5.60. The current Dynarec and Paging memory settings should be good enough to avoid thrashing. 1.0 rom paging sometimes gives more fluid play, like in Mario Kart. Tweaks to CounterFactor in 1964.ini help with speeds, but we may be pretty squeezed dry there.

#101 tacoman94

tacoman94

    X-S Enthusiast

  • Members
  • 10 posts

Posted 05 December 2011 - 01:26 AM

Can someone help me out using surreal and when i play conkers bad fur day splitscreen player 2 and p4 move by themselves. even when i switch or take out controllers. even when i try another conker bad fur day rom it still does this. even on an earlier version of surreal it still does this. can someone try this on there xbox to see if the same happens to them

#102 weinerschnitzel

weinerschnitzel

    X-S Senior Member

  • Dev/Contributor
  • PipPip
  • 279 posts
  • Xbox Version:v1.0
  • 360 version:v4.0 (jasper)

Posted 06 December 2011 - 01:47 AM

Weird. They turn left 90 degrees then face front. But they don't move on their own... My best guess is at a bug in the input plugin, but it might be PIF related. The issue stands in both 1964 and PJ64, so it's more likely the input plugin. I think N-Rage is the best one as of now, but there are also SDL input plugins. It could even be a bug in the video plugin. I'm not sure at this point.

QUOTE
I've tried using several different skins, but I can't get any of my xmv videos to show in the emulator front end ROM selection screen. The box art shows up fine, but the video showing is always the static.xmv one. I have all my videos named the exact same as their ROM file counterpart (except for the extension of course). I also have XMV preview enabled in the GUI settings. The media location is D:\media (the default). My videos are in the D:\media\movies folder. I've pressed Y to refresh, the screen goes black, and I hear the hard drive crunching for 5-10 seconds, but nothing changes. Am I missing something here? Thanks!


Videos have to follow the same names as boxart. Names follow the CRC1 of each dump chained together.

007 World Is Not Enough would be:
CRC1-CRC1.xmv
033F4C13-3B941695.xmv


#103 Ash123

Ash123

    X-S Member

  • Members
  • Pip
  • 74 posts

Posted 06 December 2011 - 10:24 AM

Just want to say thanks for the reply, Banjo-tooie now plays with those setting you suggested.

Can I ask what the dynarec/paging/max video memory does and how changing the values affects the gameplay and what the limitation are?

Or is there a page where theses functions are explained in detail?

Thanks.

#104 xboxmods2977

xboxmods2977

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,156 posts
  • Xbox Version:v1.0
  • 360 version:none

Posted 08 December 2011 - 04:21 AM

I've actually got GoldenEye running awesome on my 128mb box. The only issue I have is when I play with a friend on 2 players. the game locks up and I have to reset the Xbox.

During 1 player mode, I can sit there for hours without a problem and play. Matter of fact I have played all the way through Secret Agent (the cradle was a b*tch without cheats, lol) and have just unlocked those last 2 or 3 maps that aren't available from the start without a single hang up.

Switch to multi-player, and the game usually freezes within the first or second match with only 2 players.

Close, yet so far away.

When I can get my hands on a stopwatch, I am gonna unlock the Invincibility cheat.

Level: Facility
Difficulty Level: Double Agent
Target time: 2:05

#105 Xmodder deluX

Xmodder deluX

    X-S Senior Member

  • Members
  • PipPip
  • 184 posts
  • Xbox Version:v1.6
  • 360 version:unknown

Posted 09 December 2011 - 10:58 AM

@xboxmods2977: I played Goldeneye to death on the old N64 back in the day. That invincibility cheat was a tough one to get but I did it! It would be nice to see multiplayer running full speed on the xbox without freezing. I am looking forward to playing Goldeneye and other retro games on my android tablet when I get it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users