Jump to content


Photo

Dash Launch v2.22


  • Please log in to reply
54 replies to this topic

#31 mrdude2478

mrdude2478

    X-S Member

  • Members
  • Pip
  • 73 posts

Posted 20 June 2011 - 12:28 AM

QUOTE(Midnight Tboy @ Jun 20 2011, 12:15 AM) View Post

you couldn't even restore by booting to xell/xellous with the eject key?

Not a good sign with this then...potentially bricking quite a few 360s...especially for those that bought their 360 prejtagged.........or in my case, though having jtagged a xenon ages back, my current jasper I didnt do, nor do I have the flasher (and my soldering skills are crap - took an age to do first one)


No m8, xell started booting then just froze - a nand reflash was needed. On another note though I did manage to get my xbox 1 games booting by reflashing dashlaunch v2.22.

I made a mistake an edited launch.ini with notepad - so I re-edited it with ultraedit and reflashed and now everything is working fine again.

Cheers.

#32 xboxhaxorz

xboxhaxorz

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,194 posts
  • Location:Virginia
  • Xbox Version:v1.6
  • 360 version:v3.0 (falcon)

Posted 20 June 2011 - 01:52 AM

if you didnt install the jtag wires yourself and bought it then you should never get something when it comes out. give it a while, sometimes dash launch releases a new version right after to fix the new bugs.

i havent updated mine yet. still waiting just to be safe.

#33 Midnight Tboy

Midnight Tboy

    X-S X-perience

  • Members
  • PipPip
  • 446 posts

Posted 20 June 2011 - 03:20 AM

QUOTE(xboxhaxorz @ Jun 20 2011, 01:52 AM) View Post

if you didnt install the jtag wires yourself and bought it then you should never get something when it comes out. give it a while, sometimes dash launch releases a new version right after to fix the new bugs.

i havent updated mine yet. still waiting just to be safe.



I agree.....at the moment I'm on the first of the kinect dashboards smile.gif No need to update yet as everything so far works fine for me.

There will be a time its needed however I'm sure.

Only downside then, is playing catchup on how to/new methods/current best one. I don't even know what xell etc I'm on, or what nand size is right now smile.gif

and of course with it being my first jasper....to find whether I need to manually remap bad blocks (if it had any in first place)...or rely on xell/xellous to flash and do that (flash360 used to mess up my old xenon because it didnt sort out the bad block that was early on in the nand).....

BUT I do have other dashlaunch problems from the last version (usb/memory unit detection when not inserted on bootup)...so woulda been nice to see if it fixed it

#34 hmx123

hmx123

    X-S Enthusiast

  • Members
  • 8 posts

Posted 20 June 2011 - 04:30 AM

QUOTE(DaSoP @ Jun 19 2011, 08:43 AM) View Post

I have a problem with dashlaunch 2.22.
I just installed 13146 to my falcon and everything went fine!
When I installed dashlaunch (after choosing the settings) did a restart and my console freezes at the starting video!!!
I did everything (flash,settings,install dashlaunch with different settings) at least 10 times and again it freezes at the starting video....
any ideas? sad.gif


...I had the same problem with my falcon ...flashed it so many times and I ended up messing up xellous (not sure how) ...so I had to put back my lpt cable ...it was a pain 'cause my horrible soldering skills (my xbox is the only jtag I've ever done tongue.gif)

...so I ended up flashing a backup of freeboot 12611 with nandpro and dashlaunch 2.22 installed just fine (I think I'm not going to try to update again for a wile)

#35 cory1492

cory1492

    X-S X-perience

  • Members
  • PipPip
  • 317 posts
  • Location:Canada
  • Xbox Version:v1.2
  • 360 version:v3.0 (falcon)

Posted 20 June 2011 - 04:55 AM

If you guys are having problems with it, it needs to be fixed... obviously that is going to require some coherent information to find out what the problem actually is (or at least a method to reproduce the issue, "tried everything" is a little too vague, because I've literally tried everything at least twice, on both a jasper and falcon console, and never had similar issues.)

The 1.0 version of swap.xex is going to cause problems, be sure it's not set as a plugin in any of your ini files or at least make sure you are using the 1.1 version. Dig around on the root of your drives, and make sure there is no kxam.patch anywhere, the new check for version should remove that as a problem source... but you never know.

Pay attention to what the installer is saying, if it says it wants to install patches for a xenon when you have a falcon... or asks you (with a warning) to install patches twice, something is definitely wrong. Make sure you aren't copying the install folder over a previous version, you won't get the current launch.xex/lhelper.xex if you do that and that can cause big problems. Older versions of freestyle/fsd had problems that became apparent when "autologin doesn't work, often" was fixed in dash launch, make sure you aren't using an old version of freestyle.

Last but not least, you can use xextool to extract the installer's resources
CODE
XexTool.exe -d resource default.xex

this will give you a folder called "resource" with files like "13146z" (patches_zephyr.bin for 13146) (z=zephyr, x=xenon, j=jasper, f=falcon) "lhelper" (lhelper.xex) and "launch" (launch.xex)... if you put lhelper.xex and launch.xex beside fbbuild exe, you can build images with it already installed. This will bypass any issues with the installer itself, and the rest is going to come down to ini issues. Using a USB key with a launch.ini on it is very helpful to try different settings to see if you can find the problem one, as USB keys are relatively fast (compared to USB hdd) and the USB ini will be loaded before/over any other.

QUOTE(Midnight Tboy @ Jun 19 2011, 08:20 PM) View Post
BUT I do have other dashlaunch problems from the last version (usb/memory unit detection when not inserted on bootup)...so woulda been nice to see if it fixed it

This was initially thought to be a dash launch problem... but turned out to be a FSD problem. Give it a go, run anything BUT FSD (xexmenu, nxe, games) and see if removing/adding a USB stick gives you an issue. If you still have a problem then, please post back.

Edited by cory1492, 20 June 2011 - 04:56 AM.


#36 DaSoP

DaSoP

    X-S Enthusiast

  • Members
  • 15 posts
  • Location:Greece
  • Xbox Version:v1.0
  • 360 version:v3.0 (falcon)

Posted 20 June 2011 - 07:23 AM

cory you are the man!!!
THANK YOU!!!
My mistake was that I used the same folder for every version of dashlaunch!!! I didn't notice that this folder had 2 other folders from the older versions of dashlaunch! I deleted the folders and installed dashlaunch just fine!!!
My Falcon is working perfect right now booting straight to FSD!!!
Although I have never used swap.xex the problem was with the older patches!
Guys DO NOT use the old dashlaunch folder! Use a new one!!!
Thank again cory! That's what I mean explanation! biggrin.gif

#37 Midnight Tboy

Midnight Tboy

    X-S X-perience

  • Members
  • PipPip
  • 446 posts

Posted 20 June 2011 - 11:49 AM

QUOTE(cory1492 @ Jun 20 2011, 04:55 AM) View Post

This was initially thought to be a dash launch problem... but turned out to be a FSD problem. Give it a go, run anything BUT FSD (xexmenu, nxe, games) and see if removing/adding a USB stick gives you an issue. If you still have a problem then, please post back.



Though not sure if you've seen my recent thread about it ( http://forums.xbox-s...howtopic=732471 ) .....I suspect it possibly is. Well, since removed the ini file entirely, though booting to NXE, it's been working fine.....so must have been either to do with what was in the ini or FSD itself (recent version but an update rather than clean install).

I've been planning to reapply the ini file, but with just the basics in, to FSD, and then see what happens, and if worked, then add each of the options........but may likely just set FSD to boot from a trigger button reset if it still does it with the basics

Edited by Midnight Tboy, 20 June 2011 - 12:33 PM.


#38 SilentBob1638

SilentBob1638

    X-S Senior Member

  • Members
  • PipPip
  • 251 posts
  • Location:Germany
  • Xbox Version:v1.0
  • 360 version:v4.0 (jasper)

Posted 21 June 2011 - 12:31 AM

QUOTE(ryanbverwoerd @ Jun 18 2011, 11:03 PM) View Post
to anyone who has updated their jtag to 13146, do your profiles still work? I'm sure quite a few of us have modded them with an xuid to make avatar dlc work. Well this new dash is doing the same thing the official update does, it CORRUPTS modded profiles. Surely since we have jtags this check should of been removed.
Yep, if its another security check it should be removed. Until then you can convert your profile back to 'offline' state. I've done so already.


#39 Midnight Tboy

Midnight Tboy

    X-S X-perience

  • Members
  • PipPip
  • 446 posts

Posted 21 June 2011 - 12:50 AM

QUOTE(cory1492 @ Jun 20 2011, 04:55 AM) View Post


This was initially thought to be a dash launch problem... but turned out to be a FSD problem. Give it a go, run anything BUT FSD (xexmenu, nxe, games) and see if removing/adding a USB stick gives you an issue. If you still have a problem then, please post back.


yup you're right - have got DL v2.22 on now. And as you say, same problem.....the moment FSD is loaded, it then locks down your usb ports (and MU ports) so can't swap anything about.

Not sure if that applies to guitar/wired controllers mind......hope they fix that with the new dash if it ever appears.

#40 steplay29

steplay29

    X-S Member

  • Members
  • Pip
  • 65 posts

Posted 21 June 2011 - 01:10 PM

had the same problem.installed dashlaunch 2.22 onto my jtag (jasper 512mb)rebooted 360 and it kept freezing on boot log (panic sets in).dont have nandpro or anything to erase my nand,so i just boot into xellous again and loaded my 13146 updflash.bin and it worked.everything is now ok and boots up with no problems at all.

#41 rami1

rami1

    X-S Young Member

  • Members
  • Pip
  • 44 posts

Posted 21 June 2011 - 01:24 PM

I want power on with start button to goto nxe (Sfc:\dash.xex)
Maybe it is better to have specific startup setting like:
PowerOn_Start= Hdd:\FSD2\default.xex or Sfc:\dash.xex
PowerOn_Guide = Hdd:\FSD2\default.xex or Sfc:\dash.xex
PowerOn_Power = Hdd:\FSD2\default.xex or Sfc:\dash.xex
PowerOn_Remote = Hdd:\FSD2\default.xex or Sfc:\dash.xex




#42 steplay29

steplay29

    X-S Member

  • Members
  • Pip
  • 65 posts

Posted 21 June 2011 - 04:34 PM

hi guys,

below is my settings for dashlaunch 2.22 on jtag dash 13146.could you please tell me if this is ok:

launch ini:
[QuickLaunchButtons]
BUT_A=:hdd1:\fsd2\default.xex
BUT_X =:hdd1:\Content \ 0000000000000000 \ C0DE9999 \ 00080000 \ C0 DE99990F586558
BUT_Y =hdd1:\fsd\default.xex
Start =
Back =
LBump =


[Settings]

nxemini = true
pingpatch = true
contpatch = false
fatalfreeze = false
fatalreboot = true
safereboot = false
regionspoof = false
region = 0x7FFF
dvdexitdash = true
xblaexitdash = true
nosysexit = false
noupdater = false
DEBUGOUT = false
exchandler = false
dumpfile =
BootDelay = 0x2A
liveblock = true
livestrong = false

and the setting i using when updating dashlaunch ie:press either a for or b for no:
Do you want to be Able to relaunch from miniblade NXE dash in?
Press A

Do you want to enable ping limit fbdev's patch?
Press A

Do you want to enable mojobojo's content patch unlock?
Press B

Do you want the console to freeze on fatal errors?
Press B

Do you want the console to reboot on fatal errors?
Press A

Do you want to enable Ability to spoof with RB region game on launch?
Press A

When the default item is set and you are playing a video, exit back to NXE
Press B

When you are playing an XBLA game and use the exit option, exit to NXE
Press B

Do you want to remove the Ability to go to system settings via miniblade
Press B

#43 aotta

aotta

    X-S Enthusiast

  • Members
  • 12 posts

Posted 22 June 2011 - 09:18 AM

QUOTE(steplay29 @ Jun 21 2011, 01:10 PM) View Post

had the same problem.installed dashlaunch 2.22 onto my jtag (jasper 512mb)rebooted 360 and it kept freezing on boot log (panic sets in).dont have nandpro or anything to erase my nand,so i just boot into xellous again and loaded my 13146 updflash.bin and it worked.everything is now ok and boots up with no problems at all.


so, you resolved the usb freeze at bootup simply reflashing the 13146? and did you reapply the dashlaunch 2.22?

#44 spider2

spider2

    X-S Young Member

  • Members
  • Pip
  • 39 posts

Posted 22 June 2011 - 03:11 PM

It isnt working for me. One time freez when booting and another time I can't switch off with the controller. I put back 12611 and 2.21 dash launch and now perfect again. I don't know what is the problem...

I tried this and same problem all of them:
12611 and 2.22
12625 and 2.22
13146 and 2.22


#45 moeom

moeom

    X-S Senior Member

  • Members
  • PipPip
  • 177 posts
  • Location:USA
  • Xbox Version:v1.4
  • 360 version:v4.0 (jasper)

Posted 22 June 2011 - 07:05 PM

QUOTE(spider2 @ Jun 22 2011, 10:11 AM) View Post

It isnt working for me. One time freez when booting and another time I can't switch off with the controller. I put back 12611 and 2.21 dash launch and now perfect again. I don't know what is the problem...

I tried this and same problem all of them:
12611 and 2.22
12625 and 2.22
13146 and 2.22



To be absolutely sure you're removing the extra folders in the installer directory (as seen in, pre-2.22 dashlaunch), I'd format the USB stick and make sure you don't have any folders nested inside the "installer" folder.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users