Jump to content


Photo

Mupen64-360 v0.96 beta


  • Please log in to reply
31 replies to this topic

#16 Pjoto

Pjoto

    X-S Member

  • Members
  • Pip
  • 76 posts

Posted 25 September 2011 - 02:30 AM

I have a JTAG Falcon newest Dashboard in chase that matters.

Sorry for the newbie question, but I downloaded it and extracted it to the root of my external drive.
The .elf is at the root, and the folder remains unchanged.
Then downloaded and installed XellLaunch, swapped the xell.bin with the xell-2f.bin from the XellReloaded package and booted it up through the FSD2A File Browser.
(renamed the original xell.bin to xell_bkup.bin, and xell-2f to xell.bin)

Xell Reloaded boots up, but it doesn't find the emulator. It just says "Waiting for link.."

The external drive is FAT32.


Any idea what I'm doing wrong? I've been waiting for a good N64 emulator ever since I got this new stupid TV that doesn't take SCART.
Thank you Lord there is still life in the emulator scene smile.gif Love you guys and your work biggrin.gif

edit:

maybe it isnt xell-f2.bin i'm supossed to use?
which is it? i got xell-1f.bin , xell-f2.bin ,and xell-ggggg.bin .

I tried" xell-reloaded-2stage-2011-09-23.rar (141.95 kB )"

Now it's stuck at "Requesting dhcp.."

Edited by Pjoto, 25 September 2011 - 03:14 AM.


#17 Twis7eD

Twis7eD

    X-S X-perience

  • Members
  • PipPip
  • 348 posts
  • Location:Chicago, IL
  • Xbox Version:unk
  • 360 version:v5.0 (360S - trinity)

Posted 25 September 2011 - 04:36 AM

QUOTE(infidelity @ Sep 24 2011, 02:53 PM) View Post

Very impressive for a first release.

Ocarina of time actually shows the beating heart.

Turok 1 was able to run a little bit.

Conkers bad fur day wouldnt load, the loading bar would appear, then it would just stay at the rom menu.

Perfect dark had incredible speed during gameplay.

Now, for me, when I press back, wanting to get back to the rom menu, everything freezes. I have to unplug my 360, and reboot xell each time i want to try another rom.

There's a noticeable lag in control/button response time.

Nothing saved for me as well. Oot, Mario 64, the saves were not present. I'm not sure if this is due to the emulator crashing when I try to exit a rom.

I would love for the user to be able to select 4:3 original aspect ratio.

Conker's Bad Fur Day doesn't load for me either. As for the freezing issue, that doesn't happen to me. I haven't had any problems with freezing yet, so that may a problem on your end only.

#18 Pjoto

Pjoto

    X-S Member

  • Members
  • Pip
  • 76 posts

Posted 25 September 2011 - 05:30 AM

Got it working.

Had to use the XellLaunch .xex provided somewhere on this page. Look for yourselfes, I don't think it's allowed to post direct links to .xex files on xbox-scene.

http://www.elitemods...-xell-reloaded/

And the xell-2f.bin renamed as xell.bin in the same folder, from this package:

xell-reloaded-2stage-2011-09-23.rar (141.95 kB )

It wouldn't work the first time. Then I placed some roms in a folder and tried again, then it suddenly worked.
But now it stopped working again.

It loads the elf, but it stops at "trying to make sence of dvd, let's assume it's iso 9660".

It feels kinda weird, considering it worked a few minutes ago.
I'll try with another USB tomorrow. But it's 05:30 at night now, so, nity.

Any other ideas? It'd be great if I didn't have to change USBs every time I want to play N64 smile.gif


edit:

Some games froze to me, some didn't.
Mario Kart and Diddy Kong Racing did not freeze, While Goldeneye did.

All games had lag in controller response. Most noticable in Mario Kart. Diddykong lagged to much in general to play.

After Goldeneye froze, I can't get the emulator up and running again. It just stops at "trying to make sence of dvd, let's assume it's iso 9660".

Edited by Pjoto, 25 September 2011 - 05:36 AM.


#19 kainy

kainy

    X-S Member

  • Members
  • Pip
  • 72 posts

Posted 25 September 2011 - 04:21 PM

I wonder...

I read at several placed that cracked Dashboard is being delayed because some people refuse to make it following the will of GliGli, that his hack would not be used for piracy...

Isn't making a N64 emulator (excluding the fact that it's done with libxenon) a way to promote piracy? You are giving people a chance to play games from N64 backups, which is great, but is still piracy. Isn't this a little bit hypocritical?

Edited by kainy, 25 September 2011 - 04:22 PM.


#20 Pjoto

Pjoto

    X-S Member

  • Members
  • Pip
  • 76 posts

Posted 25 September 2011 - 09:02 PM

You're only supossed to play games you already own.
Like, most of us have a N64 with loads of games laying around in our addicts or something, just collecting dust. I know I do, mostly because my stupid new TV won't work with my analog N64 cable thingy, pluss there's no room for it in my livingroom. There'd just be too much wires.

So a N64 emulator is just perfect! Making it so I can download the games I already own physicly, and can play them with my xbox360 and wireless controllers on my bigass TV.


On another note:
I'm loving it! I'll be following updates for this like a hawk!
My biggest issues right now are problems with the USB, sometimes it finds it, sometimes it doesn't. Then I have to power off my xbox and take out the cable, boot with eject, power off, then start it up again and start XellLaunch with the emulator. Then it seems to work, sometimes.
So it's kinda dodgy. Is that because of the emulator or because of Xell Reloaded or the USB?

And then there's the slight lag in the controllers.

And no save.

Other than that, it's an incredible release!

Edited by Pjoto, 25 September 2011 - 09:04 PM.


#21 ruciz

ruciz

    X-S X-perience

  • Members
  • PipPip
  • 333 posts

Posted 26 September 2011 - 09:46 PM

QUOTE(Pjoto @ Sep 25 2011, 09:02 PM) View Post

You're only supossed to play games you already own.


exactly, so.. why the hold up with the modified dashboard again?

also, at least in the US (not sure where you are located) its illegal to have a backup of anything, and its defiantly illegal to download that backup instead of using your Z64 or similar to make the ROM from your store bought original.

Either way, its a hypocritical situation as theres a LOAD of homebrew for the 360 (freestyle dash, FFplay, HDDX formatter, etc) in XEX form that will not run on gligli's hack.. also you cannot play your store-bought originals WITH the hack. you can play Mupen64 and Tank360. Definatly worth a dedicated 360 console!

Everyone is in FAT/FAT32 USB format right? and have RTFM?
This is a port of Wii64 - so its a N64 emulator that was built for the wii, thats been ported to 360... That screams reliability. esp version 0.96B! Its amazing its even working to be honest. I can't wait for the '360 hardware tweaks' to make it look bomb on a 1080p set.

Edited by ruciz, 26 September 2011 - 09:52 PM.


#22 ravendrow

ravendrow

    X-S Senior Member

  • Members
  • PipPip
  • 285 posts
  • Xbox Version:unk
  • 360 version:v5.0 (360S - trinity)

Posted 27 September 2011 - 12:21 AM

k so a few things

A. quit friggin crying about a damn rebooter (gligli spent 1 1/2 years developing the RGH and YES! those of us who can build a rebooter refuse to out of respect for him)

B.if you want one so damn bad you spend the weeks required to modify libxenon and xell to run all the required files (it is more complicated than a jtag because you can't just use the kernel exploit)

C.keep your damn panties on jtag consoles weren't full rebooters at first shit for a while there you could only run xell. it will happen in time

so now that i got that out of my system...to everyone using xelllaunch try updating your console to xell reloaded with xell updater then just use the eject button (xell launch is iffy in my opinion) i haven't had any problems loading mupen that way. as for save states they very much do work i am half way threw my zelda OOT game and i got the save file to prove it lol. and lastly if you guys want to keep the most up to date you can on this and other projects like libxenon or xell install the toolchain and compile this stuff yourself. it's not rocket science and who knows maybe you have something you can contribute to the scene

#23 cancerous1

cancerous1

    X-S Young Member

  • Members
  • Pip
  • 59 posts
  • Interests:Lurking. ive been around...
  • Xbox Version:unk
  • 360 version:unknown

Posted 28 September 2011 - 12:02 PM

QUOTE(Pjoto @ Sep 25 2011, 09:02 PM) View Post

"trying to make sence of dvd, let's assume it's iso 9660".



try taking the disk out of your dvd drive?

Thanks GliGli for all the hard work. Love it.

#24 xmugen360

xmugen360

    X-S X-perience

  • Members
  • PipPip
  • 328 posts

Posted 11 October 2011 - 03:34 PM

yup cancerous i think you figured out his problem....basically xell seems to get hung on certain devices while i am sure it can be fixed it would take quite an effort when you have these issues unplug external hd's and switch to small flash memory thumb drives and or burn it all to a dvd xexnon.elf mupen and your roms and poof....

Look as far as the complaints about the rgh not having hacked dash puhleeze save it for another thread i for one could care less...if you want a hacked dash so bad code it urself otherwise wait...ur kidding urself if the entire community has the same scruples..a group somewhere out there will make one and it will leak...in time of course...

As for the actual emu i was on the floor jaw agape! Amazing performance graphically...I guess it does look kinda wierd cause it isn't 4:3 i never even realized though. Damn thing looked amazing to me on my screen...buuuuut...I never even tried to save seemed like a wasted effort i just cared how i moved around in my old stomping grounds...here is what i noticed...Wave Race 64 (a favorite game of mine) has analog stick dead spots it seems. Like I know this game by heart and I can easily perfect whole run either on original hardware or xbox...at first I thought heck am I rusty nope...it seems if I tilt analog stick sharply in certain directions I just get no response...which this game requires...Super Mario 64 felt nice though.

Running via hdmi no sound issues...check your settings hdmi sound is supported...

#25 OggyUK

OggyUK

    X-S Freak

  • Last Chance
  • PipPipPipPipPip
  • 1,876 posts
  • Location:Northants, UK
  • Xbox Version:unk
  • 360 version:unknown

Posted 11 October 2011 - 05:50 PM

I agree it looks fantastic, but GoldenEye got 10x harder using a 360 controller smile.gif

I do not fancy Control on 00 Agent on this. grr.gif

#26 xmugen360

xmugen360

    X-S X-perience

  • Members
  • PipPip
  • 328 posts

Posted 11 October 2011 - 06:23 PM

which to be honest shouldnt be the case it should be waaay more responsive i feel...mayhaps wireless issue? I wonder if wired controller work better...

#27 Pjoto

Pjoto

    X-S Member

  • Members
  • Pip
  • 76 posts

Posted 11 October 2011 - 06:58 PM

This is awsome smile.gif

He's still working on it, his blog is posting updates.

Can't wait for the next binary release. I'm having some problems with saving and returning to the menu on this one. It just freezes my machine and won't save. Annoying having to start all over again on every game tongue.gif
No biggie, but can't wait for a more stable version smile.gif

You are amazing! Keep it up!

love.gif


QUOTE(sith @ Sep 23 2011, 06:15 PM) View Post

Incredible! what amazing achievements by GliGli and Ced2911 over the last little bit. Thank you so much!

Maybe a stupid question.. but will libxenon software such as this ever be launch-able via a GOD(or other package) from a rebooted MS dash?

.sith.


I used Quickboot (PC application) to create a GOD out of the .xex for XellLaunch.
This way I can boot XellLaunch from the QuickLaunch-menu. The other files still have to be put like explained in the readme.txt, but you don't have to boot it from FSD or whatever each time.

#28 Spooning

Spooning

    X-S Young Member

  • Members
  • Pip
  • 58 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 12 October 2011 - 12:05 AM

QUOTE(xmugen360 @ Oct 11 2011, 04:34 PM) View Post

Running via hdmi no sound issues...check your settings hdmi sound is supported...


...but not for me so it seems.That drives me nuts lol

Settings uhh.gif
TV is switched on and working fine
Xbox360 is switched on and working fine too jester.gif

Xell boots up and loads mupen64 from stick
Via component I get sound (I love Tetrisphere btw. THX Gligli)
Via Hdmi no sound

My specs.
Falcon CB 5770
Dash 13146
Flashed Xell 23-09-11

Greetings wink.gif






#29 Pjoto

Pjoto

    X-S Member

  • Members
  • Pip
  • 76 posts

Posted 13 October 2011 - 01:42 AM

QUOTE(ravendrow @ Sep 27 2011, 01:21 AM) View Post

to everyone using xelllaunch try updating your console to xell reloaded with xell updater then just use the eject button (xell launch is iffy in my opinion) i haven't had any problems loading mupen that way. as for save states they very much do work i am half way threw my zelda OOT game and i got the save file to prove it lol.


1. Do you mean Save states or just normal save as in the games? I don't mind if it freezes every now and then if I can save-state before pressing "back".

2. I installed Xell Reloaded and felt kinda hacky about it (first time doing anything like that on a xbox), but it doesn't change anything. It still freezes when I press the back button, and nothing saves to me. How is your setup? Do you use a big external hdd or a thumbstick? I want to get my Zelda on too, but I'm getting tired of that long intro. "Navi, come hiter. Fly Navi fly! The fate of the forest, nay! the world! depens upon thee!" Haha. Epic.

3. Is it possible to have a big USB for Xbox-games and homebrew and such, and a USB-stick, dedicated just for this emulator?
And if I were to burn the emulator and roms onto a DVD, how would it save? DVDs are read only, or well, they aren't, but anyway, Xbox-DVD-roms can't burn. So how does it save?

4. I know there's a option in DashLaunch called something like "USB Sleep true/false" or something, does that affect homebrew booted through Xell? And if so, what should I set it too (because it's kinda confusing. I have everything set to "true" in my launch.ini)? Because it almost seems like my USB hdd goes to sleep, and that's why it doesn't boot the .elf sometimes, and that's why it freezes when I try to go back or save. My USB HDD is a 600GB FAT32 formatted with a program that formats any size hdd into FAT32. It works almost perfectly with everything else on my Xbox (sometimes I have to take it out and plug it back in again for my Xbox to recognize it). All other games/programs run flawlessly when first booted.

5. Thoughts? Ideas? Thanks smile.gif

6. And thanks for an awsome first release! I haven't played around with my JTAG this much in ages!

Edited by Pjoto, 13 October 2011 - 01:48 AM.


#30 eliastico

eliastico

    X-S Enthusiast

  • Members
  • 8 posts

Posted 21 February 2012 - 10:23 AM

Is there a way to save state? Or do the in-game memorypak saves work? I couldn't Find a way to save state.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users