Jump to content



No Internet Connection On My Jtag 360

  • Please log in to reply
3 replies to this topic

#1 peterablex


    X-S Enthusiast

  • Members
  • 9 posts
  • Location:Dordrecht, The Netherlands
  • Xbox Version:unk
  • 360 version:v3.0 (falcon)

Posted 26 September 2011 - 10:16 PM

Hi everyone!

This is my last straw, I've searched and I've searched and I can't find a solution so maybe you guys can help me out. I will try to sketch the situation as clear as possible.

Some time ago I bought a new fat 360 from a modshop which was already JTAG'ed. XEX menu is installed, but I only run games from the original dash (which is the Kinect dash at the moment) as GoD containers. I have absolutely no problems doing anything game-related, let that be clear. The modshop is currently out of business so I can't take my question to them.

The problem is that I can not connect to the internet, for cool things implemented in FSD for example. I have no problem connecting to my network and even Windows Media Center works like a charm. Whatever I try, whatever I do, if I test the connection it fails every time at the internet part. I have tried it many times, both ethernet and wireless, and though every other device in my home connects flawlessly, the darn Xbox will not connect.

Ayt, my modem connects to my E3000 Cisco router which provides the computers upstairs with internet connection. A cable from the router goes to the switch downstairs which has the PS3, X360, Wii, Media streamer etc. plugged into it. Now all these devices work just fine except for the 360.

Things tried
I've tried both wired and wireless connection, manual and automatic setup in the Xbox, many suggested things on the router forums, checked the DNS servers and what have you not. Nothing works. Network yes, internet no.

Is it possible that the guys who JTAG'ed the Xbox have somehow fried something that would block the internet connection or that they might have altered or configured a file that restricts internet? Via XEX menu I can access a number of files with the .xex extension which are on the flash memory but I don't know much about that so I'm not tampering with that.

Any suggestions would be great, thanks in advance!

#2 dazv6


    X-S Member

  • Members
  • Pip
  • 104 posts
  • Xbox Version:none
  • 360 version:v3.0 (falcon)

Posted 04 October 2011 - 09:32 PM

If you figure this out m8 please share as iv got the same problem with my jtag.


#3 peterablex


    X-S Enthusiast

  • Members
  • 9 posts
  • Location:Dordrecht, The Netherlands
  • Xbox Version:unk
  • 360 version:v3.0 (falcon)

Posted 05 October 2011 - 08:01 AM

Actually I DID figure it out yesterday!

I decided to follow this tutorial to set Freestyle Dash to launch at start:


After I installed/updated Dash Launch and followed the configuration options given in the tut, internet worked! I guess it doesn't mean you have to follow the complete tut like I did, just reinstalling Dash Launch with the right configuration will work smile.gif

Note: after following the guide, I updated my NXE Dash to the latest (13599), which required a newer version of Dash Launch (2.23). The configuration was basically the same as the one in the guide, except it had some extra questions/options. If you're going to use FSD RC2.1 and you want to be able to download cover art & screenshots, just make sure you DO NOT block LiveDNS when asked. Blocking Live from the NXE parental control settings described in the guide I mentioned seems to to the trick effectively anyway.

Hope this helps mate, cheers!

#4 comman


    X-S Enthusiast

  • Members
  • 8 posts

Posted 17 October 2011 - 09:44 AM

Yes. please pm me if you figure out it;thanks in advance pro.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users