Jump to content


Photo

Psu Dead, Or Just A Bad Brick?


  • Please log in to reply
2 replies to this topic

#1 anon123

anon123

    X-S Young Member

  • Members
  • Pip
  • 46 posts
  • Location:anon....isnt that the point?
  • Interests:girls, modding and game hacking, girls, guitar, girls, skateboarding, girls, comp. prog....and girls
  • Xbox Version:v1.0

Posted 19 November 2011 - 11:38 PM

I'm not sure if I had a PSU failure, but the power brick's red button does pop up when plugged in.

The thing is, even if I unplug the brick to the Xbox it still pops up.

Does the pop up feature depend on some kind of feedback mechanism from the console to ensure the system is working (in which case I would expect it to pop when not connected to the Xbox and my unplugged test is meaningless) or not (in which case I think my brick, and not my PSU, has the problem)?


#2 jaroc

jaroc

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,047 posts
  • Location:Toronto, Ontario (Canada)
  • Interests:Xbox and Sports
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 20 November 2011 - 12:49 AM

If you're talking about the replacement power cable with the red and yellow buttons, one of mine does that too, you just have to hold it in (but not all the way down) until the light stops blinking and you're good.


#3 anon123

anon123

    X-S Young Member

  • Members
  • Pip
  • 46 posts
  • Location:anon....isnt that the point?
  • Interests:girls, modding and game hacking, girls, guitar, girls, skateboarding, girls, comp. prog....and girls
  • Xbox Version:v1.0

Posted 20 November 2011 - 01:07 PM

Wow that actually worked!

Its stuck on solid red, though, now. Even though it works is that safe?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users