Jump to content


Photo

Enabling 480p Using X2vga 2?


  • Please log in to reply
24 replies to this topic

#16 gibbousmoon

gibbousmoon

    X-S Enthusiast

  • Members
  • 16 posts

Posted 01 December 2011 - 02:58 PM

QUOTE(xboxmods2977 @ Nov 30 2011, 10:49 AM) View Post

Nope. It will not. Also, name a few of the games you are having the issue with.


Baldur's Gate 1 and 2 are the latest culprits. I can find a few more, if you think that will help narrow down the problem.

#17 xboxmods2977

xboxmods2977

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,156 posts
  • Xbox Version:v1.0
  • 360 version:none

Posted 02 December 2011 - 03:23 AM

I was thinking that your issue may have something to do with "green screen" games but now I can't find the list of games anywhere.

#18 gibbousmoon

gibbousmoon

    X-S Enthusiast

  • Members
  • 16 posts

Posted 02 December 2011 - 04:26 AM

Well, thanks for trying anyhow.

Would you mind sharing with me why you don't believe that changing my dash would fix the problem?

#19 Heimdall

Heimdall

    X-S Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 5,749 posts
  • Location:UK
  • Xbox Version:v1.4
  • 360 version:v4.0 (jasper)

Posted 02 December 2011 - 04:25 PM

Because the dash doesn't set the video modes - they are set in the eeprom. The dash is just another application that can use the available video modes, it just happens to give the user control over video mode selection - whereas games don't.

#20 gibbousmoon

gibbousmoon

    X-S Enthusiast

  • Members
  • 16 posts

Posted 03 December 2011 - 02:56 AM

QUOTE(Heimdall @ Dec 3 2011, 12:25 AM) View Post

Because the dash doesn't set the video modes - they are set in the eeprom. The dash is just another application that can use the available video modes, it just happens to give the user control over video mode selection - whereas games don't.


Hmm... You think it's the x2vga 2 that's causing the problems? That's certainly a possibility, though I'm confused as to why it works fine with so many other games.

#21 xboxmods2977

xboxmods2977

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,156 posts
  • Xbox Version:v1.0
  • 360 version:none

Posted 03 December 2011 - 05:15 AM

Taken from a review of the X2VGA that I found online:
"Games really do look spectacular through the X2VGA+ and once you see the crisp HD visuals it is hard to go back to a normal TV. Games pop out at you like never before and it really feels like a different experience. I have tested everything from Halo and Halo 2 to KOTOR I and II to Need for Speed Underground 2 and everything looks gorgeous. Other games such as Jet Set Radio Future and 2D fighters like Guilty Gear X2 #Reload are so sharp you can cut yourself just looking at them. Even Enter the Matrix looks beautiful in HD. A handful of games (mostly junk from the Xbox launch) only run in 480i so they won’t work, but everything else in the Xbox library runs in at least 480p and it all looks wonderful through the X2VGA+."

Further research uncovered that on the back of the case for Baldars Gate II, 480p was not checked. This may be your problem. I did find one post where a guy says he was able to play this game using the X2VGA with no issues. I'm guessing that he had one of those rare PC monitors that could properly display interlaced resolutions.
Here is an image of the back of the case. The only feature checked is "Players: 1-2"
IPB Image
This game apparently does not support 480p, and therefore cannot be made to work with your current configuration.

regards

#22 gibbousmoon

gibbousmoon

    X-S Enthusiast

  • Members
  • 16 posts

Posted 07 April 2013 - 05:33 PM

Sorry to necro my own thread, but I've been playing with this a bit more, the issue remains the same, and I have a bit more info to go on.

I'm trying to get Castlevania: Curse of Darkness (supports up to 720p) to run on the same setup, and it exhibits the same "default to interlaced mode" problems. Halo 1 as well (and I KNOW I have run Halo 1 successfully on this setup in the past, which leads me to believe that I screwed something up somewhere and this issue can be fixed). Both of these were run from original retail NTSC discs. (My system is NTSC-J, but other than the video issue these games run fine on my system with the xecuter2 chip enabled.) Also, a hard disk copy of Flatout is newly exhibiting this problem, so I suspect it is related. A setting must have changed somewhere! (Or I changed it without knowing it.)

Finally, I ran a Japanese retail disc with the modchip disabled, and it ran fine in progressive! It now seems obvious to me what the problem is, though I still don't know how to fix it:

The xecuter2 modchip is not picking up the changes in settings from the MS dash. (480p and 720p enabled; 1080i disabled.)

How can I change the settings in my hacked dash, so that they are recognized?

I'm still using EvoX. Is there a way to change the settings in EvoxX? Are there other dashes that give the option to enable 480p / 720p / 1080i?

Edited by gibbousmoon, 07 April 2013 - 05:34 PM.


#23 Heimdall

Heimdall

    X-S Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 5,749 posts
  • Location:UK
  • Xbox Version:v1.4
  • 360 version:v4.0 (jasper)

Posted 07 April 2013 - 06:27 PM

Your question about the hacked dash has been answered more than once in this thread. The hacked dash doesn't change the Xbox video settings, it simply makes use of them for its own display. If you disable 1080i in the MSDash (which changes the settings in the eeprom) then Evox and UnleashX will never display in 1080i nomatter what you do. Again - the hacked dash has nothing to do with your problem.

Modchips don't "pick up" anything - they are simply carriers for the BIOS. Which BIOS are you using?

What happens if you do each of the following?
- Cold boot with a Japanese retail game, modchip disabled (your post implies that you get 480p, but just confirm it so we get a complete picture of the problem)
- Cold boot with a Japanese retail game, modchip enabled
- Start a Japanese retail game from your dashboard, modchip enabled






#24 gibbousmoon

gibbousmoon

    X-S Enthusiast

  • Members
  • 16 posts

Posted 10 April 2013 - 12:46 PM

I got progressive output with the modchip disabled, and interlaced SD output with it disabled, on the same Japanese retail game. I don't remember if it was a cold boot or a dash startup. I think perhaps both gave the same results.

I never did discover the problem, but I did discover the solution! I am posting it here, in case someone else has a similar issue.

Go into system utils --> Settings --> Game Region --> Auto. That fixed the issue. It was set to NTSC (U), which matches the majority of my retail games, but for whatever reason was forcing them to output in SD.

Disabling TSR fixed another issue on another thread in this forum I started that was never answered a couple years ago: that of the game freezing on the EvolutionX splashscreen. So I solved two problems in the same hour. I'll go find that thread now and update it.

Thank you very much, everyone who posted in this thread trying to help me!

EDIT:
P.S. According to this link, Baldur's Gate Dark Alliance supports 480p.
https://en.wikipedia...with_HD_support

However, I continue to get interlaced output on it. I suppose the best explanation for this is that that information is simply incorrect. I'll look into it a bit more and update this post if I find anything.

Edited by gibbousmoon, 10 April 2013 - 12:49 PM.


#25 gibbousmoon

gibbousmoon

    X-S Enthusiast

  • Members
  • 16 posts

Posted 10 April 2013 - 04:05 PM

Hmm, seems I can't edit anymore.

Sorry, that should read "I got progressive output with the modchip disabled, and interlaced SD output with it ENABLED, on the same Japanese retail game. I don't remember if it was a cold boot or a dash startup. I think perhaps both gave the same results."




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users