Jump to content


Photo

Messed Up Config.xml On Softmodded Xbox


  • Please log in to reply
12 replies to this topic

#1 five5outh

five5outh

    X-S Enthusiast

  • Members
  • 6 posts

Posted 31 December 2011 - 03:28 AM

Hey all,

I was stupid and messed up the config.xml on my EVOX- Softmodded xbox. I can play regular games but the dash goes straight to the "Yout xbox requires customer support" screen.


I tried Softy's, Frosty's, and AID Boot and they would all go straight into the "Customer support" screen.


I went ahead and tried to go through the Splinter Cell exploit that I softmodded the xbox with but it still went straight to the "Customer Support screen".


Do I have any alternatives or am I left with the hot swap method?

All i really want to do is force widescreen on my ESPN NFL 2k5 game so that it doesn't look like poopoo.


Thanks

#2 Heimdall

Heimdall

    X-S Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 5,749 posts
  • Location:UK
  • Xbox Version:v1.4
  • 360 version:v4.0 (jasper)

Posted 31 December 2011 - 03:40 AM

Evox doesn't use config.xml. Evox uses evox.ini, it's UnleashX that uses config.xml. Are you sure you know what you are doing?

Did your Xbox ever boot a rescue disc? Are your rescue discs burned to DVD-R?

If the answer to both is yes then either your DVD drive is on the way out, or you did more than mangle config.xml, because changing config.xml on a softmodded Xbox doesn't stop it from booting a rescue disc.

Edited by Heimdall, 31 December 2011 - 03:45 AM.


#3 five5outh

five5outh

    X-S Enthusiast

  • Members
  • 6 posts

Posted 31 December 2011 - 06:31 AM

All I did was point the config.xml to a busted msdash.xbe inadvertently. I'm making my boot disks on memorex dvd—rs and burning them using dvd decryptor on the slowest speed. I never used a boot disk though was able to play games from dvd-rs when it was working, same brand as well.


#4 Heimdall

Heimdall

    X-S Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 5,749 posts
  • Location:UK
  • Xbox Version:v1.4
  • 360 version:v4.0 (jasper)

Posted 31 December 2011 - 02:38 PM

Was your Xbox booting to UnleashX as its dash?

Which line in config.xml did you edit to point to msdash.xbe?

#5 five5outh

five5outh

    X-S Enthusiast

  • Members
  • 6 posts

Posted 31 December 2011 - 08:05 PM

<?xml version="1.0" encoding="utf-8" ?>
- <UnleashX>
- <Settings>
<MSDashBoard>C:\msdash.xbe</MSDashBoard>
<Password MaxTries="3" />
- <Network Enable="Yes" Type="Static">
<IP>192.168.0.2</IP>
<Subnet>255.255.255.255</Subnet>
<Gateway>192.168.0.1</Gateway>
<DNS1>0.0.0.0</DNS1>
<DNS2>0.0.0.0</DNS2>
<AutoDetect>Yes</AutoDetect>
</Network>
- <FTP Enable="Yes">
<User>xbox</User>
<Password>xbox</Password>
<Port>21</Port>
<MaxUsers>2</MaxUsers>
<AllowAnon>No</AllowAnon>
<Greeting>Welcome to XBOX FTP Server</Greeting>
</FTP>
- <Newsfeed Enable="False" Interval="30">
<URL>www.XS Filter -/html/backend.php</URL>
<URL>www.xbins.org/xbins.xml</URL>
</Newsfeed>
- <Preference>
<EnableSoundTrack Random="True" MusicPath="E:\Music">Both</EnableSoundTrack>
<Skin Path="skins\">BlueShapes - By Kthulu</Skin>
<Games AutoLaunch="No">C:\msdash.xbe</Games>
<DVD AutoLaunch="No">E:\Apps\DVDX\default.xbe</DVD>
<AudioCD AutoLaunch="No">C:\msdash.xbe</AudioCD>

<Data AutoLaunch="Yes" />
<SoundVolume>90</SoundVolume>
<MusicVolume>95</MusicVolume>
<UseFahrenheit>Yes</UseFahrenheit>
<SNTP Synchronize="No">216.244.192.3</SNTP>
<Skin Path="skins\">Default</Skin>
<FanSpeed>1.00</FanSpeed>
- <ScreenSaver Wait="30" Type="1">
<Text />
</ScreenSaver>
<AutoTurnOff>60</AutoTurnOff>
<EnableDriveF>No</EnableDriveF>
<EnableDriveG>No</EnableDriveG>
<LEDColor>Green</LEDColor>
<ContextMenu AllowItemEdit="Yes" AllowUninstall="Yes" />
<AutoPatch>No</AutoPatch>
<DefaultFolder>C:\backup</DefaultFolder>
<AutoVideoMode MultiRegion="PAL" UsePAL60="Yes">Yes</AutoVideoMode>
<AutoSetTime>No</AutoSetTime>
<VideoSettings Widescreen="Yes" FastRefresh="No" Use16bit="False" Soften="No" FilterLevel="0" Use480P="Yes" Use720P="Yes" Use1080I="Yes" />
</Preference>
</Settings>
- <Menu>
<Item Action="LaunchDVD">Launch DVD</Item>
- <List Text="Games" Sort="On" Auto="On" DelayLoad="True">
<Path>E:\Games</Path>
<Path>E:\HDDLoader</Path>
<Path>E:\GamesHomeBrew</Path>
<Path>F:\Games</Path>
<Path>F:\HDDLoader</Path>
<Path>F:\GamesHomeBrew</Path>
<Path>G:\Games</Path>
<Path>G:\HDDLoader</Path>
<Path>G:\GamesHomeBrew</Path>
</List>
- <List Text="Applications" Sort="On" Auto="On">
<Path>E:\Apps</Path>
<Path>F:\Apps</Path>
<Path>G:\Apps</Path>
</List>
- <List Text="Emulators" Sort="On" Auto="On">
<Path>E:\Emulators</Path>
<Path>F:\Emulators</Path>
<Path>G:\Emulators</Path>
</List>
- <List Text="System" Sort="Off" Auto="On">
<Item Action="Settings">Settings</Item>
<Item Action="SavesManager">Game Saves Manager</Item>
- <List Text="Misc" Sort="Off" Auto="On">
<Item Action="FTPStop">Stop FTP</Item>
<Item Action="FTPStart">Start FTP</Item>
<Item Action="FTPReset">Reset FTP</Item>
<Item Action="NETReset">Restart Network</Item>
<Item Action="TrayClose">Close DVD Tray</Item>
<Item Action="TrayOpen">Open DVD Tray</Item>
<Item Action="CopyDVD">Copy Game Disc</Item>
</List>
- <List Text="Format Menu" Sort="Off" Auto="On">
<Item Action="Format" Arg1="X">Format X Drive</Item>
<Item Action="Format" Arg1="Y">Format Y Drive</Item>
<Item Action="Format" Arg1="Z">Format Z Drive</Item>
- <List Text="Format E Drive" Sort="Off" Batch="True">
<Item Action="AskUser" Arg1="Format">Are you sure you want to format Drive E?</Item>
<Item Action="MessageBox" Arg1="Format">Press OK to proceed with the format operation.</Item>
<Item Action="Format" Arg1="E">Format E Drive</Item>
</List>
- <List Text="Format F Drive" Sort="Off" Batch="True">
<Item Action="AskUser" Arg1="Format">Are you sure you want to format Drive F?</Item>
<Item Action="MessageBox" Arg1="Format">Press OK to proceed with the format operation.</Item>
<Item Action="Format" Arg1="F">Format F Drive</Item>
</List>
- <List Text="Format G Drive" Sort="Off" Batch="True">
<Item Action="AskUser" Arg1="Format">Are you sure you want to format Drive G?</Item>
<Item Action="MessageBox" Arg1="Format">Press OK to proceed with the format operation.</Item>
<Item Action="Format" Arg1="G">Format G Drive</Item>
</List>
</List>
<Item Action="Skins">Skins</Item>
</List>
<Item Action="FileManager">File Explorer</Item>
<Item Action="C:\xboxdash.xbe">MS Dashboard</Item>
<Item Action="Restart">Reboot</Item>
<Item Action="Shutdown">Shutdown</Item>
</Menu>
</UnleashX>

This is a working version of my XML before i messed it up in my xbox..


I basically changed all instances of C:\msdash.xbe to C:\xboxdash.xbe.....which when going to the xboxdash.xbe made me go straight to the "Customer Service" screen in the beginning.


I tried burning a boot disc once again, and it still doesn't want to cooperate. Used IMGBurn and DVD Decryptor on Memorex DVD-Rs.


If i can FTP into the system without a dashboard, somehow I feel that I can just replace the config.xml and all will be well lol.






#6 xboxmods2977

xboxmods2977

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,156 posts
  • Xbox Version:v1.0
  • 360 version:none

Posted 02 January 2012 - 06:00 PM

Do you have an eeprom backup?

#7 five5outh

five5outh

    X-S Enthusiast

  • Members
  • 6 posts

Posted 04 January 2012 - 05:30 AM

I do not =\

#8 fallenangle

fallenangle

    X-S Genius

  • Members
  • PipPipPipPip
  • 924 posts

Posted 05 January 2012 - 01:53 AM

You say you tried to use the Splinter Cell exploit; were you using an original copy and correct region SC disc?

I ask because I had no problem cold booting Splinter Cell even when the particular Xbox was otherwise stuck via a normal boot on an Error 21, Error 13 or the Xbox LIve screen.

What I don't understand is how messing just with the config.xml can stuff the softmod. Is this possible I ask the expert persons here?

An error problem like this sounds, to me, more like the main UnleashX dash .xbe may have been replaced, deleted or moved.






#9 five5outh

five5outh

    X-S Enthusiast

  • Members
  • 6 posts

Posted 06 January 2012 - 12:34 AM

Yes I was using an original copy as my xbox is ntsc. The SC copy i got is NTSC.

I would go through the exploit but then it would take me to the "customer service needed" screen. If I could get into the xbox via FTP through any means possible then I could possiblly just re-config the config.xml to point to the correct dash.

Back when it was working, if I would select "Go to MS Dashboard", then it would black out, then go back to the UnleashX dash.


If I were to select it manually, it would do the same. If I were to select the msdash.xbe, then it would give me the "Customer Service" screen.

The last time I checked, I forced the region to be PAL. So, even if my savegame is NTSC, do I need a PAL SC disc?

#10 Heimdall

Heimdall

    X-S Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 5,749 posts
  • Location:UK
  • Xbox Version:v1.4
  • 360 version:v4.0 (jasper)

Posted 06 January 2012 - 12:58 AM

It sounds as though you used a really old and not very good softmod......

I suspect that your only option is to use a post 2004 live-enabled game to reset the dash to its original state, then redo the softmod using the Krayzie 1.1.1 gamesave installer.

#11 five5outh

five5outh

    X-S Enthusiast

  • Members
  • 6 posts

Posted 06 January 2012 - 07:36 AM

Any you suggest?

I have NFL2k5 that is pretty post-2004 live.. but before I sign on it says that I don't have any gamertags.. even though I played online with it in the past

#12 fallenangle

fallenangle

    X-S Genius

  • Members
  • PipPipPipPip
  • 924 posts

Posted 06 January 2012 - 02:41 PM

Any game should do if it says Live Online Enabled on the box.

What I'm really not sure about is if you have region changed it previously to PAL using Enigmah whether any particular NTSC game will successfully update the dash. You may perhaps need to find either a region free NTSC or genuine PAL Live Online Enabled game. I've looked at the best resource I know and NFL2k5 is not listed as a region free game.

However there's no reason not to try first any Live Online Enabled game you have whatever the region. If it does update the the dash it should be obvious.

Just out of interest: is your NTSC SC game actually cold booting correctly ie. does the intro and FMV run and you can get to the Checkpoints > Linux screen? I ask because the original release SC is not shown as region free so if your Xbox is booting your NTSC SC disc the console is likely still set to NTSC.

-----------------------------------------------------------------------------------------------------------------------------

This raises a few things I hadn't thought about before: consider a game save softmod using PAL SC and the appropriate PAL SC exploit/installer but then later region changed the console to NTSC. Assume you still have the PAL exploit/installer saves 'safely' on your HDD; under similar circumstances to fiveSouth's problem surely the original PAL SC used for the softmod now wouldn't work. The console is NTSC so PAL SC won't boot, therefore no FTP access.

Then what if instead you used a NTSC version of SC? Would that load the PAL version exploit game save and load the installer dash and allowing you to FTP?






#13 fallenangle

fallenangle

    X-S Genius

  • Members
  • PipPipPipPip
  • 924 posts

Posted 06 January 2012 - 10:24 PM

I think I've answered my own question.

On my v.1.1 Xbox softmoded with an old SID version (PAL SC) now regioned changed to NTSC I've just successfully cold booted my original PAL SC disc and it loaded the installer dash (Linux > Checkpoints etc) no problem.

This, of course, was done on a fully functional softmodded Xbox but, as said earlier, it also worked with a dodgy Xbox softmod (not my work BTW smile.gif ) that was getting those various error screens mentioned.

What that suggests unfortunately is that there shouldn't have been a problem getting to the installer dash for FTPing using fiveSouth's NTSC SC disc.

Fingers crossed that Heimdall's advice about using a Live enabled game to re-establish a working dash will succeed.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users