Jump to content


Photo

About Playing The Newer Games [help!] [xgd3] [lt 1.9/2.0/3.0]


  • Please log in to reply
6 replies to this topic

#1 pkpikachu

pkpikachu

    X-S Enthusiast

  • Members
  • 4 posts

Posted 10 February 2012 - 07:11 AM

Sorry if it's on the wrong section!!

So, it's been a while since I've played any Xbox 360 games (last one was FF13). Recently I've tried to play a burnt copy of NFS:The Run only to find an error message (Update not found: This game requires an update, but the update could not be found).

I've read on the forums and around the internet and found lots of things about the new XGD3 games, anti-piracy measures and updating drives to LT2.0 or 3.0 but nothing I found really fits my situation.

I have an older model bought early 2007, flashed by a friend, with a Samsung drive. I was caught in the May 2007 ban wave and have never been online since. So I don't use my console online at all.

Since that day, the only modifications I made were dashboard updates (currently on 2.0.8955.0) via USB.

I want to know what do I have to do to play the newer games (specifically NFS: The Run and FF13-2) without having to reburn old games to make these work.

Should I update my dashboard? Will it require me to reflash the drive (I've read it resets it to factory settings)?
Should I update my drive to LT2.0 or 3.0? (I suppose I have 1.9?)
Should I use ABGX before burning the discs?

Thanks a lot!!!

#2 dougiegillam

dougiegillam

    X-S Senior Member

  • Members
  • PipPip
  • 218 posts
  • Location:North Wales.UK
  • Interests:Computing,cycling, running
  • Xbox Version:unk
  • 360 version:v5.0 (360S - trinity)

Posted 10 February 2012 - 08:52 AM

QUOTE(pkpikachu @ Feb 10 2012, 08:11 AM) View Post

Sorry if it's on the wrong section!!

So, it's been a while since I've played any Xbox 360 games (last one was FF13). Recently I've tried to play a burnt copy of NFS:The Run only to find an error message (Update not found: This game requires an update, but the update could not be found).

I've read on the forums and around the internet and found lots of things about the new XGD3 games, anti-piracy measures and updating drives to LT2.0 or 3.0 but nothing I found really fits my situation.

I have an older model bought early 2007, flashed by a friend, with a Samsung drive. I was caught in the May 2007 ban wave and have never been online since. So I don't use my console online at all.

Since that day, the only modifications I made were dashboard updates (currently on 2.0.8955.0) via USB.

I want to know what do I have to do to play the newer games (specifically NFS: The Run and FF13-2) without having to reburn old games to make these work.

Should I update my dashboard? Will it require me to reflash the drive (I've read it resets it to factory settings)?
Should I update my drive to LT2.0 or 3.0? (I suppose I have 1.9?)
Should I use ABGX before burning the discs?

Thanks a lot!!!

Download the latest dashboard to usb stick and update your console then re flash to LT 2.1 for samsung drives. And yes its always a good idea to run the games via ABGX banned or not. Suggest you read the Jungleflasher tutorial first.

#3 CLaeR

CLaeR

    X-S Young Member

  • Members
  • Pip
  • 34 posts
  • Location:Russia
  • Interests:Xbox 360, Playstation 3, Fun
  • Xbox Version:unk
  • 360 version:v3.0 (falcon)

Posted 10 February 2012 - 08:53 AM

For play nfs you have to update dash.
1.After it you can flash lt 2.1and patch nfs:the run with abgx 1.0.6
2. Yes its good to verify with abgx before burning

Edited by CLaeR, 10 February 2012 - 08:54 AM.


#4 steveo1978

steveo1978

    Super Moderator

  • Head Moderators
  • PipPipPipPipPip
  • 1,966 posts
  • Gender:Male
  • Location:north carolina
  • Xbox Version:v1.2
  • 360 version:v4.0 (jasper)

Posted 10 February 2012 - 08:55 AM

Yes to all your questions and use lt+ 3.0. Just use newest Xbox backup creator to rerip alll your games. On XGD3 games you will need an iHAS drive flashed with the Max Burner firmware to get a full burn though.

#5 Rammieone

Rammieone

    X-S Member

  • Members
  • Pip
  • 111 posts
  • Location:Uk
  • Interests:Xbox Live<br />Football <br />Computers
  • Xbox Version:v1.6b
  • 360 version:v4.0 (jasper)

Posted 10 February 2012 - 10:08 AM

QUOTE(steveo1978 @ Feb 10 2012, 07:55 AM) View Post

Yes to all your questions and use lt+ 3.0. Just use newest Xbox backup creator to rerip alll your games. On XGD3 games you will need an iHAS drive flashed with the Max Burner firmware to get a full burn though.




This guy is a little mixed up mate so do not go looking for Lt3 for the Sammy as there is none its 2.1 the latest firmware mate!

Samsung currently does not need v3.0 as isn't an AP2.5-capable drive. LT+ v3.0 is only needed for drives which support AP2.5 (Hitachi 78/79, BenQ, Lite-On). ISOs made for v3.0 that include topology data will work fine on Samsung and old Hitachis. In v3.0, the ISO layout hasn't changed, except that there will instead be new topology data in place of where the old AP2.5 replay sector used to be, which Samsung & old Hitachis ignore anyway.

#6 pkpikachu

pkpikachu

    X-S Enthusiast

  • Members
  • 4 posts

Posted 10 February 2012 - 10:30 PM

So first I update the dashboard to the latest one.
Then I reflash the Samsung drive to 2.1 with jungleflasher 1.92.

Will this prevent my pre-XGD3 games from running? I'd rather not lose this compatibility if there are other options...

My drive's firmware is hacked, but I don't which version (I'm reading the 1.4.4 tutorial, does the current firmware make any difference?)

Thanks again

#7 dougiegillam

dougiegillam

    X-S Senior Member

  • Members
  • PipPip
  • 218 posts
  • Location:North Wales.UK
  • Interests:Computing,cycling, running
  • Xbox Version:unk
  • 360 version:v5.0 (360S - trinity)

Posted 11 February 2012 - 10:02 AM

QUOTE(pkpikachu @ Feb 10 2012, 11:30 PM) View Post

So first I update the dashboard to the latest one.
Then I reflash the Samsung drive to 2.1 with jungleflasher 1.92.

Will this prevent my pre-XGD3 games from running? I'd rather not lose this compatibility if there are other options...

My drive's firmware is hacked, but I don't which version (I'm reading the 1.4.4 tutorial, does the current firmware make any difference?)

Thanks again

Your old games should run fine on the Samsung after the Update/flash. And the 2.1 samsung firmware will run XGD3 titles fine now.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users