Jump to content



Dvd Drive Swap Issues

  • Please log in to reply
4 replies to this topic

#1 Angate


    X-S Enthusiast

  • Members
  • 3 posts

Posted 02 March 2012 - 12:26 AM

I have an xbox with a Phillips Light On DG-16D2S that is no longer reading games. I bought a new laser for it and the laser wouldn't read anything and it was grinding (maybe a wrong laser on my part) so I bought a new drive and did a logic board swap and now am getting an E64 error on boot. I have done a logic board swap on a BenQ drive before with no problems though. Should I try to do a SN/FW swap from the drives and use the new drive? I have looked all over the internet and feel dumb because I can't figure this out. I found the xbox tool kit but can't figure out what to do with it.

Any suggestions?

#2 MadMaxGR


    X-S Hacker

  • Members
  • PipPipPipPipPipPip
  • 2,815 posts
  • Gender:Male
  • Location:Cyprus
  • Xbox Version:v1.6
  • 360 version:v4.0 (jasper)

Posted 02 March 2012 - 09:14 AM

E64: DVD Drive Error - Dvd drive timed out during reset :Wrong firmware, dvd is without f/w chip, etc. This can also be caused by the tray not being fully closed on boot. also it could mean that the Kernel can't be launched/signature in NAND Flash chip is broken It could be possible after bad update. http://forums.xbox-s...p;#entry4156375 This might also be caused by a bad SATA cable.

Obviously you have two choices:

a. replace the SATA cable with a new one and try again
b. If the (a) doesn't work, you have to read the DVD key from the broken Lite-on and inject it in the new drive. Probably the DVD board has a fault and you get that error, and strange drive behavior.

Good luck smile.gif

#3 Angate


    X-S Enthusiast

  • Members
  • 3 posts

Posted 02 March 2012 - 05:21 PM

Ok so I have not yet tried a new cable but I will as soon as I get back to the box. If that does not work, I found this: Key Extract method, but It requires making a serial bridge. Is there a way to do this through the sata cable into a computer rather than serial?

#4 Angate


    X-S Enthusiast

  • Members
  • 3 posts

Posted 02 March 2012 - 06:50 PM

Ok, swapping SATA cables worked, but the new drive is acting just like the old one. It will allow you to start a game but will freeze up almost immediately.

Edited by Angate, 02 March 2012 - 06:54 PM.

#5 GoTeamScotch


    X-S X-perience

  • Members
  • PipPip
  • 438 posts
  • Location:Washington, USA
  • Xbox Version:v1.4
  • 360 version:none

Posted 03 March 2012 - 06:56 AM

I know if you have the power connector in upside down it will throw an on screen error code, so that may have been what happened.

About the drive: Are you sure your source on the new drive is reliable? If you bought it used, there's a chance you inherited a drive with problems. Just a thought.

My suggestion is this- clean the lens thoroughly with a Q-tip & alcohol. If no luck then perform a POT tweak, if no luck then replace the laser. If none of those fix it it could be software based so update your software or try playing without the HDD to see if that is where the problem lies.

Good luck!

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users