Jump to content


Photo

Perplexing Ponderment Of History Of This Xbox Dvd Drive.


  • Please log in to reply
4 replies to this topic

#1 filletofish

filletofish

    X-S Senior Member

  • Members
  • PipPip
  • 152 posts

Posted 08 March 2012 - 04:39 PM

Okey dokey, before I begin just to clarify this is actually a resolved problem but still doesn't answer some questions I don't quite understand.

A friend had an Xbox 360 MFR date of late 2006, at least the case says so. Inside was a Samsung MS28 with MFR date of November 2006. (before MFR). He updated from a dashboard that didn't flash DVD drive to one that *might* have he doesn't know version (yes I know some people and their lack of information!). The update bar froze half way through and rebooting results in a working Xbox 360 but not updated. He passed it round to a few people and I told him to tell them to flash it to stock. For some reason they couldn't sort it. Normal original games would work, but XGD3 originals\backups would demand update and it still not update. (From what I later did, it would seem they didn't have a clue and left a spoof active)

He gave it to me, when I dumped the firmware it had Samsung LT 2.01 on it spoofed to a Liteon 78450c. Weird, since that drive hadn't even been released when this Xbox was made, I asked him what the hell was going on and he said he bought it off a friend a year or two ago. I know this person he bought it off knows how to JTAG and what not and mess around with keyvaults etc. So he could have done some messing around with it potentially.

Anyways, I know recent dashboards don't work with spoofed drives, so decided to remove the spoofing and just flash the normal stock Samsung MS28 with his key, the Xbox 360 would now update no problem but XGD3 originals still wouldn't work. This would imply (i think?) that the console definately didn't have a Samsung MS28 in it originally, correct?

I then took my 8xxxx drive and flashed it with his key and latest 0251c LT3.0 firmware and bingo all worked fine.

So I told the silly sod to order a 78450c off ebay and I would flash it with his key and 0251c etc and it should work. So it now works fine and he's a happy chappy, boots backups\originals XGD3\anything fine - no problem.

Anyways.....

Does anyone know from what I have said what is going on here, it sounds darn strange.

Could this have been a repair from Microsoft, baring in mind the MFR is 2006, how could it be expecting a drive that can do XGD3...

It's a curiosity more than anything, I guess the final question is when it comes to a new dash update should problems be anticipated and maybe require putting the old Samsung MS28 in for the update to complete successfully.

I was quite annoyed really as I only asked for a tenner.

But hey ho smile.gif

Edited by filletofish, 08 March 2012 - 04:41 PM.


#2 smuddge37

smuddge37

    X-S Senior Member

  • Members
  • PipPip
  • 193 posts

Posted 08 March 2012 - 05:44 PM

ms repaired and put in liteon drive.
happens all the time.


#3 Aldanga

Aldanga

    X-S Hacker

  • Head Moderators
  • PipPipPipPipPipPip
  • 2,722 posts
  • Gender:Male
  • Interests:Hardware,software,coding,algorithms, troubleshooting, tinkering with anything I can get my hands on.
  • Xbox Version:none
  • 360 version:v5.0 (360S - trinity)

Posted 08 March 2012 - 05:49 PM

smuddge37 is right. I have a 2006 Xenon that was repaired by MS back in 2007 and the Samsung drive was replaced with a LiteOn.

#4 filletofish

filletofish

    X-S Senior Member

  • Members
  • PipPip
  • 152 posts

Posted 08 March 2012 - 07:58 PM

Thank you both very much indeed for the answers.

I can now sleep easy biggrin.gif

#5 mod_irl

mod_irl

    X-S Member

  • Members
  • Pip
  • 105 posts

Posted 09 March 2012 - 07:14 PM

Or maybe the motherboard in the xbox doesnt match the case that says 2006, could be a newer xbox in an older case, ive seen this once or twice, people mixing and matching parts.

Edited by mod_irl, 09 March 2012 - 07:15 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users