Jump to content


Photo

Repairing A Corrupt Data Save


  • Please log in to reply
No replies to this topic

#1 reezel

reezel

    X-S Enthusiast

  • Members
  • 1 posts

Posted 08 March 2012 - 09:07 PM

About a year ago I moved all of my saves to a 4GB USB stick to give myself more DLC room on my hard drive. Unfortunately something happened and suddenly it didn't even show up as a valid USB stick for the 360 anymore. I took the initiative then and copied the data to multiple locations so that I would be able to keep a copy in case I could fix it. I have now researched a number of times how to fix it but nothing has ever worked for me. I was hoping someone here might be able to assist me.

If I take the old Xbox360 folder and copy it back to the USB stick, it just plain out doesn't work. The Xbox tells me that it is not a proper device and needs to be formatted.

Some research told me that I should format the drive on the 360 and then copy all the files on it but data0000. I have tried this and I get the same message.

I have tried the same process but excluded both data0000 and data0001. When I try this, my Xbox suddenly looks at is if it knows all those files are still there but they are all corrupt. This was the first thing that gave me some hope I could recover my files.

Once in that state, I have gotten both modio and USBXTAFGUI to recognize the drive as a valid drive and show me the save files that are on there. The problem is once I try to export them or do anything with them it tells me the files aren't there and error out.

Here's my speculation. I think that the Data0001 file is the corrupt. I am guessing it is the master record detailing where on the disk my save files actually are and once it is not properly formatted it sees that they should be there but cannot find them. Unfortunately I don't actually know how to read this file or if it is even possible. If anyone out there might have some idea on how I might be able to fix this problem I would be hugely thankful. I am more annoyed by this now since I just started ME3 and it is killing me I cannot import my character I have been playing with since the beginning.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users