Jump to content


Photo

Hitachi 47 Freezes In Windows


  • Please log in to reply
3 replies to this topic

#1 cerealkillajme

cerealkillajme

    X-S Messiah

  • Head Moderators
  • PipPipPipPipPipPipPip
  • 3,241 posts
  • Gender:Male
  • Location:The Den
  • Xbox Version:v1.6
  • 360 version:v1 (xenon)

Posted 06 April 2012 - 12:12 AM

Back from the dead... ph34r.gif

I've modded about 100 360s in the past, but have been out of the loop the last 3 years for the most part. I've done a few Samsungs and BenQs for friends, but I haven't touched a Hitachi in years...

The drive is a stock 47DG. I'm using JF and have managed to dump the FW over both WinAPI and PortIO, but I can't get the thing to flash.

I have 3 SATA cards:
VIA 6421 (removed VIA drivers per JF tutorial and used PortIO)
Sil 3512A (I'm pretty sure this is the card I used to use for Hitachi drives back in the day)
Highpoint Rocketraid 1520 (pretty sure I did my first Samsungs with this and got the VIA 6421 when the ms28 came out)

I have been able to get the drive into mode B using PortIO and WinAPI. I get a drive letter in JF and Windows using the Sil 3512A card and WinAPI, and the drive responds to the query command as well.

But whenever I try to flash the FW over WinAPI it says "Dumping:." and freezes JF until I shut the 360 off.
Whenever I try to flash the FW over PortIO it says "drive Unlocked and mode select or ram upload failed".

Mode B confirmed by 2 button press, and the drive gets assigned a letter.

I have tried all of this on 2 different PCs.

I'm kind of at a loss and feel that I must just be overlooking something small at this point.

#2 shambles1980

shambles1980

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,092 posts
  • Location:wales uk
  • Xbox Version:v1.2
  • 360 version:v4.0 (jasper)

Posted 06 April 2012 - 04:19 AM

i had a nightmare with these drives.
for me it was all to do with the power cycle. I had to do it like 3-4 times bewfore it worked (quickly)

doubt it will help you any but i hate these drives personally.

#3 crazygoldfish

crazygoldfish

    X-S Senior Member

  • Members
  • PipPip
  • 233 posts

Posted 06 April 2012 - 09:45 PM

Check cables are in right, I had a hitachi do the same thing recently

#4 cerealkillajme

cerealkillajme

    X-S Messiah

  • Head Moderators
  • PipPipPipPipPipPipPip
  • 3,241 posts
  • Gender:Male
  • Location:The Den
  • Xbox Version:v1.6
  • 360 version:v1 (xenon)

Posted 08 April 2012 - 02:45 AM

Spent about 5 or 6 more hours on it today. In total I spent about 20 hours messing with this one.

I successfully got the drive flashed. I switched back to using the VIA 6421 with the drivers removed. I noticed that if I sent a "ram upload" command to the drive, I needed to do it within the first few seconds of the drive going into Mode B (via JF Mode B command). I noticed that if I did it within about 3-4 seconds it would start dumping the flash and then hang. If I did it within 2-3 seconds it might dump the flash, then hang while flashing (2 sectors flashed and then the rest got "ram upload failed" I thought I nearly bricked the drive 2x this way FFS). Finally when I did it within about 1 second it worked and dumped and flashed everything.

So here is the final process I had to use (power supplied by 360).

1. Open JF with "via ports only" and "port IO"
2. Select FlashLT
3. Send the Mode B command (open drive, power off, hit OK)
4. Power on 360
5. Mode B command done message, hit "flash LT" (ram upload) within about 1 second.
6. Should do a full dump and flash.

I've flashed over 100 360s and I can honestly say this was the hardest one of them all and the only one I felt like I was even close to bricking at any point.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users