Jump to content


Photo

Hitachi 47 Won't Play Xgd3


  • Please log in to reply
1 reply to this topic

#1 mrmilo69

mrmilo69

    X-S Enthusiast

  • Members
  • 12 posts

Posted 07 May 2012 - 03:47 PM

I have an xbox with a Hitachi 47 and up until about 2 weeks ago I could play Street Fighter x Tekken in backup form but one day it just stopped. Put in my original and same error. "Disc Unreadable" So I replaced the drive and installed SFxT onto my Hard drive. 100% completion so I thought great, went to start the game up and again "disc unreadable".

How can the same disc that copied all the data to the hard drive now be unreadable? I have tried SFxT original and backup and my MW3 but nothing doing. I even swapped the PCB from my old hitachi to the new and did all the flashing back up to date and exactly the same. Has anyone encountered this problem?

An another note I just pulled out my old copy of Pro Evolution 2005 to play a friend on yesterday and the disc even though has seen better days worked like a charm. What is going on? I can still access live etc so I don't see how I can be banned. Is there something I have overlooked?

#2 krizalid

krizalid

    X-S Expert

  • Dev/Contributor
  • PipPipPip
  • 612 posts
  • Location:Mexico
  • Xbox Version:none
  • 360 version:v5.0 (360S - trinity)

Posted 10 May 2012 - 07:54 AM

Hitachis are known to be very peeky and weak when it comes to reading burnt media.

Try either pot calibratión, laser replacement but I would defenetly recomend drive upgrade to either BenQ or LiteOn.

Good Luck.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users