Jump to content


Photo

Avisynth Script And Wmenc Errors


  • Please log in to reply
No replies to this topic

#1 Dagosd

Dagosd

    X-S Enthusiast

  • Members
  • 1 posts

Posted 08 June 2012 - 02:12 AM

I am attempting to encode to Windows Media Professional 10 with WMEnc, but the I keep getting an error "Failed(hr=0x00d0bc6) in converter.Initial( EncParams.szIn, FALSE, EncParams.szOut, EncParams.pProfile, FALSE, TRUE, FALSE, -1)[b]" ffdshow is set to 5 channels with LFE selected.


I've cleaned my systems of Codecs. I reinstalled Windows 7 Codecs.
Installed Windows Media Codec, Expression for encoding.

I demux and extracted DTS with MKVextract.

I then used Tranzcode, 6 mono, and output to wav.
After I encoded with Belight to AC3.
Remux the AC3 with the MKV ( Is there anyway, at this step, without remuxing for WMEnc with Avisynth script to extract the ac3 for encoding into Windows Professional Audio?

I created an avs file which contained "DirectShowSource("I:\Downloads\Movies\Project.mkv")". (am I missing something in the script?)
Selected the input AVS file, selected output, unselected "Use Video" and set it to "Windows Audio Professional 10 384kbps, 48kz, 5.1 channel 24bit CBR"

And encode
Get error "Failed(hr=0x00d0bc6) in converter.Initial( EncParams.szIn, FALSE, EncParams.szOut, EncParams.pProfile, FALSE, TRUE, FALSE, -1)[b]"


What is this error? Could it be the remux with the MKV? Alternatively, is there anything out there that would convert AC3 to Windows Media Audio? Perhaps a script with Avisynth?







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users