Jump to content



4gb External Usb Drive Doesn't Work Properly

  • Please log in to reply
4 replies to this topic

#1 ntrp


    X-S Enthusiast

  • Members
  • 2 posts

Posted 18 September 2012 - 09:15 PM

I just modded a xbox cable to enable external periperal plugging. Everything seems fine except when I try to edit a file on my 4gb usbkey (fat32) the file is empty.. When I copy an emulator folder to my internal drive it copies fine but it doesn't work and all files are empty when opened with the editor.

I'm using UnleashX on a SmartXX v2.3 modded 1.6 Xbox, all the data I copied through FTP some years ago is working fine, just the stuff on the key dosen't want to open.

The strange bit is that the files have size and the filesystem is intact on the key opened through the unleashX file manager but if I try to open it with the editor it shows up empty.. If I try to open a zip file it says that it is corrupt but it show it's size..

The worst problem is that my network ICS is gone, probably because of lightning, and my druve doesn-t read shit so I cannot copy files unless I fix this external USB.. Anyway I am planning on replacing the Network ICS but I need to order it and do the work with little to no experience or tools sad.gif

p.s. can it be that the modded usb cable is too long?

PLS HALP!!! sad.gif

#2 ldotsfan


    X-S Messiah

  • Dev/Contributor
  • PipPipPipPipPipPipPip
  • 3,100 posts
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 19 September 2012 - 02:06 PM

Have you tried FATX instead? On the PC, you can use xplorer360 to transfer files to the usb drive.

#3 ntrp


    X-S Enthusiast

  • Members
  • 2 posts

Posted 19 September 2012 - 03:23 PM

QUOTE(ldotsfan @ Sep 19 2012, 03:06 PM) View Post

Have you tried FATX instead? On the PC, you can use xplorer360 to transfer files to the usb drive.

I love you man love.gif It's working! By the way what's the deal with Fat32? why it doesn't work? I though Fat32 was fine on XBOX :/

About the Network ICS, do you happen to know if it is removable with a 300 C Hot Air blow gun? Or should I use a low power (I've got a 30W) soldering iron?

I tried removing some IC from waste boards with the HotAir Gun and I managed it (the board seems fine after the operation) but I don't know if the boards could have suffered some damage because I can't test them.

#4 fallenangle


    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,085 posts

Posted 19 September 2012 - 05:01 PM

FATX is the format system the Xbox uses and with MS and UnleashX dash will usually automatically reformat a compatible FAT16/32 memory device just by attaching it. You usually get a message but sometimes it just does it.

However, I've found that if you hot mount a FAT32 formatted flash drive when using XBMC it won't be reformatted and will be shown correctly as FAT32 in XBMC File Manager. You seem to be able to transfer files from the Xbox to it with no problem and from there to PC. But if you try it in reverse ie. FAT32 memory device to Xbox the Copy and Move options will not be available (greyed out).

How well or if at all a USB memory device works with the Xbox has always been a bit of a lottery. FTP is far less hassle.

Edited by fallenangle, 19 September 2012 - 05:19 PM.

#5 hangover


    X-S Expert

  • Members
  • PipPipPip
  • 675 posts
  • Location:Melbourne, Australia
  • Xbox Version:v1.4
  • 360 version:v4.0 (jasper)

Posted 20 September 2012 - 11:24 AM

As above unleashx doesnt mount or read fat32 drives and XBMC will only read it but not write, it will read/write to fatx though . I have also found that on a softmodded console if you leave the flashdrive in the usb port on boot up it will format the drive as fatx and wipe it , this doesnt happen on chipped/tsop'd consoles.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users