Jump to content


Photo

No Power.......


  • Please log in to reply
3 replies to this topic

#1 Stripe007

Stripe007

    X-S Enthusiast

  • Members
  • 2 posts

Posted 27 September 2012 - 05:02 AM

Hello everyone. I have an Xbox 360 halo 3 edition with power issues. I get a momentary green light blinking on the console itself when i push the eject button (i can not get power any other way) and then the light on my power supply goes from orange to red and the console is dead. I checked the power supply and it functions properly on my other xbox. Any suggestions on what the likely culprit is. Thanks in advance.

#2 Weirdjerz3y

Weirdjerz3y

    X-S X-perience

  • Members
  • PipPip
  • 455 posts
  • Location:United states
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 27 September 2012 - 06:48 AM

Well, have you touch it? Any mods you did? We need more details. Did you reflow it with heatgun, or x-clamp it and then this happened? Do you get 1.8v and 3.3v on the MOSFETs that lead to the southbridge?

#3 Stripe007

Stripe007

    X-S Enthusiast

  • Members
  • 2 posts

Posted 27 September 2012 - 07:11 AM

No mods have been done. I broke the seal to take a look and i don't see anything obviously wrong. All of the USB Ports look good and nothing is shorting out there. I took a can of air to it because it was extremely dusty. I have not tried any repair yet because i would like to find best approach based on my symptoms. I have tried to research and see if any one has had problems similar to mine but everyone elses seem a bit different. I have yet to check for voltage in the appropriate places. I'm not sure where to start

#4 wilgo45

wilgo45

    X-S Expert

  • Members
  • PipPipPip
  • 708 posts

Posted 27 September 2012 - 11:01 AM

Sounds like there is a short.

Or there could be a bad connection in the female side of the power plug.

It's going to have to be opened and checked over. First thing to do is read for standby voltage on the motherboard. There is a particular spot for that.

Then the drain side on two particular power regulators need to be metered in DC volts.

Go back and check all your ports again also. Remember there is also a USB port on the back side.

Good idea to check the port of the ROL board too. And the memory dock ports




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users