Jump to content


Photo

Can You Install The Old Xtreme Firmwares On The Newest Dashboard?


  • Please log in to reply
2 replies to this topic

#1 cloudboy

cloudboy

    X-S Member

  • Members
  • Pip
  • 86 posts

Posted 06 October 2012 - 08:03 AM

Someone told me that he had some backup games that worked fine, then he bought Halo Anniversary and backed it up, but it made him update the dash. he returned the disc to stock, updated the dash, and put on the newest lt+3.0. now, however, even the older backup games will no longer work. Is it possible to flash his drive with an older version of ixtreme to make the old games play again? (he doesnt care about xbox live)

#2 ARY

ARY

    X-S Young Member

  • Members
  • Pip
  • 54 posts
  • Location:Russia
  • Interests:Support flashing Xbox 360
  • Xbox Version:none
  • 360 version:none

Posted 06 October 2012 - 08:25 AM

If he sure that drive was flashed correctly, the disks have old patches.
You can flash LT20 instead 30. But it will be better to reburn disks with LT30 patches

Edited by ARY, 06 October 2012 - 08:27 AM.


#3 cloudboy

cloudboy

    X-S Member

  • Members
  • Pip
  • 86 posts

Posted 06 October 2012 - 08:30 AM

why? with lt2.0 do you have to patch the games?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users