Jump to content


Photo

Realx Issues


  • Please log in to reply
13 replies to this topic

#1 XDAWG

XDAWG

    X-S Expert

  • XS-BANNED
  • PipPipPip
  • 657 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 02 September 2003 - 06:40 AM

EDIT: ereased because of update in second post.

Edited by XDAWG, 04 September 2003 - 06:59 AM.


#2 XDAWG

XDAWG

    X-S Expert

  • XS-BANNED
  • PipPipPip
  • 657 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 02 September 2003 - 07:32 AM

UPDATE got it to work but doesnt work correct my setup should be:
SHARE
c:pictures
c:music
c:videos

But in xbmp I only have 1 folder its movies thats folder isnt even listed above

here is my config:
<local>
<!-- remove the asterisks to set local ip address and gateway statically -->
<address>192.168.1.4</address>
<subnet>255.255.255.0</subnet>
<gateway>192.168.1.1</gateway>
<nameserver>192.168.1.175</nameserver>
<playlists>e:appsxbmpplaylists</playlists>
<timeserver*>207.46.248.43</timeserver*>
<thumbnails>e:appsxbmpthumbs</thumbnails>
<bookmarks>e:appsxbmpbookmarks</bookmarks>
<subtitles>e:appsxbmpsubtitles</subtitles>
<imdb>e:appsxbmpimdb</imdb>
<home>e:appsxbmp</home>
</local>

<!-- specify as many shares as you like, note the format for each type of share -->
<!-- Note: XNS shares are created using RelaX, SMB shares are Windows shared folders -->
<!-- for each share you can specify the cache buffer size, note that this is optional -->
<music>
<visible>true</visible>
<share>
<name>ShoutCast</name>
<url>e:musicshoutcast</url>
</share>
<share>
<name>RELAX</name>
<url>c:music@192.168.1.3</url>
</share>
<share>
<name>Network (XNS)</name>
<url>c:sharedmusic@192.168.1.2</url>
<cachesize>256</cachesize>
</share>
<share>
<name>Network (SMB)</name>
<url>smb://username:password@workgroup/computer/share</url>
<cachesize>256</cachesize>
</share>
<share>
<name>HDD</name>
<url>e:music</url>
</share>
<share>
<name>Playlists</name>
<url>e:appsxbmpplaylists</url>
<cachesize>32</cachesize>
</share>
<share>
<name>DVDROM (UDF)</name>
<url>d:</url>
</share>
<share>
<name>DVDROM (ISO9660)</name>
<url>iso9660:</url>
</share>
</music>

<pictures>
<visible>true</visible>
<share>
<name>RELAX</name>
<url>c:pictures@192.168.1.3</url>
</share>
<share>
<name>Network (XNS)</name>
<url>c:sharedpictures@192.168.1.2</url>
<cachesize>256</cachesize>
</share>
<share>
<name>Network (SMB)</name>
<url>smb://username:password@workgroup/computer/share</url>
<cachesize>256</cachesize>
</share>
<share>
<name>HDD</name>
<url>e:pictures</url>
</share>
<share>
<name>DVDROM (UDF)</name>
<url>d:</url>
</share>
<share>
<name>DVDROM (ISO9660)</name>
<url>iso9660:</url>
</share>
</pictures>

<videos>
<visible>true</visible>
<share>
<name>RELAX</name>
<url>c:movies@192.168.1.3</url>
</share>
<share>
<name>Network (XNS)</name>
<url>c:sharedvideos@192.168.1.2</url>
<cachesize>8192</cachesize>
</share>
<share>
<name>Network (SMB)</name>
<url>smb://username:password@workgroup/computer/share</url>
<cachesize>8192</cachesize>
</share>
<share>
<name>HDD</name>
<url>e:video</url>
<cachesize>8192</cachesize>
</share>
<share>
<name>Playlists</name>
<url>e:appsxbmpplaylists</url>
<cachesize>32</cachesize>
</share>
<share>
<name>DVDROM (UDF)</name>
<url>d:</url>
<cachesize>8192</cachesize>
</share>
<share>
<name>DVDROM (ISO9660)</name>
<url>iso9660:</url>
<cachesize>8192</cachesize>
</share>
</videos>

Atleast it works I guess I will just have to put everything in that folder.

XDAWG

Edited by XDAWG, 02 September 2003 - 08:08 PM.


#3 XDAWG

XDAWG

    X-S Expert

  • XS-BANNED
  • PipPipPip
  • 657 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 02 September 2003 - 05:54 PM

All these people talking about relax and no one can help me out I tried to be as detailed as I could. dry.gif

XDAWG

Edited by XDAWG, 02 September 2003 - 05:55 PM.


#4 w m z

w m z

    X-S Hacker

  • Members
  • PipPipPipPipPipPip
  • 2,378 posts

Posted 02 September 2003 - 05:59 PM

Your PC ip address is

My PC settings (static)
IP-192.168.1.3

Yet your config.xml is . . .

name>RELAX</name>
<url>c:\music@192.168.0.1</url>
</share>

Its been a while for me but i am pretty sure Relax runs on your PC. Therefore is should read . . .

name>RELAX</name>
<url>c:\music@192.168.1.3</url>
</share>

Hope this helps wink.gif



#5 XDAWG

XDAWG

    X-S Expert

  • XS-BANNED
  • PipPipPip
  • 657 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 02 September 2003 - 08:12 PM

w m z Thanks for the reply I did fianlly get it to work as I stated in the above post UPDATE. I didnt want to make a complete post again due to the size of the post so I just edited my other one. Thank again.

XDAWG beerchug.gif

#6 xboxmookie

xboxmookie

    X-S Enthusiast

  • Members
  • 15 posts

Posted 03 September 2003 - 02:14 PM

Hey... I noticed that you have multiple computers using your XNS/Relax file sharing method. Ex. 192.168.1.2 and 192.168.1.3. I was wondering if you were having the same problem that I am.

Even though my config.xml is all correct... which ever computer I select first in XBMP seems to be the computer all the rest of the XNS/Relax links take me too... until i reset the xbox and select a different computer first. Ive checked all the IP's over and over and I'm wondering if you are having this problem with your to XNS sources. This was never a problem with XBMP 2.3.

thanks

#7 XDAWG

XDAWG

    X-S Expert

  • XS-BANNED
  • PipPipPip
  • 657 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 03 September 2003 - 11:50 PM

Sorry I cant help you out on this I dont really know shit about it I tried for 2 days to get it to work but I couldnt get it working properly. It does work but not as it should but Im tired of fuckin with it actually the only thing really that bothers me is I have to play my music through my vidoes settings because my music folder is not listed. I dont know why but through relax I have it set to.

SHARES
c:vidoes
c:music
c:pictures

But all I get when I run on xbmp+relax is 1 folder called Movies and I have to put all my stuff in that folder and run my music through my videos in xbmp. I wish I could get it situated but for now I can live with it and shoutcast doesnt connect it times out everytime. I think it might be how I have my network setup through NICs. Acually I dont have any other PC connected so I cant help you out I only have 1 PC to Xbox with an NIC.

XDAWG

#8 xboxmookie

xboxmookie

    X-S Enthusiast

  • Members
  • 15 posts

Posted 04 September 2003 - 01:51 AM

Well... in response to your problem... most people I know actually dont configure anything inside of relax. they just run it and have the xbox just log into the c drive... so if you set your url to
<url>c:@192.168.1.2</url>
you will just log into your c drive and then you can browse all the folders in the c drive. just leave relax with on with nothing but the word shares appearing on the left hand side. then everything should work

later

#9 XDAWG

XDAWG

    X-S Expert

  • XS-BANNED
  • PipPipPip
  • 657 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 04 September 2003 - 06:58 AM

Thanks for the Tip man changed it to c: and now everything except shoutcast works I have been trying to get this for a couple days. Everything seemed more complicated than it actually was. Now Im going to try to get shout cast running I think I have to make my NIC share a connection with the internet. Then I will try to configure some shoutcast stations. wink.gif

XDAWG

#10 explicitlyrics100

explicitlyrics100

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,045 posts
  • Location:London
  • Interests:everything
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 04 September 2003 - 11:26 PM

mookie, if you have multiple pc's with drives you want to share, map them all on one pc, run relax on that pc. put all those dirs in an invisible dir called moves for example... then in xbmp config type this
<share>
<name>Network (XNS)</name>
<url>$ROOT$Movies@192.168.1.2</url> (or the ip of the pc which has all drives mapped)
<cachesize>8192</cachesize>
</share>

#11 xboxmookie

xboxmookie

    X-S Enthusiast

  • Members
  • 15 posts

Posted 05 September 2003 - 07:05 PM

explicitlyrics100,
Not quite sure how to use relax. Can you explain how to map out the drives from other computer's onto mine.

mookie

#12 explicitlyrics100

explicitlyrics100

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,045 posts
  • Location:London
  • Interests:everything
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 06 September 2003 - 09:45 PM

i sent u an email about it, chris

#13 explicitlyrics100

explicitlyrics100

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,045 posts
  • Location:London
  • Interests:everything
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 06 September 2003 - 09:50 PM

ahhh heck, basically, go into network places, go to tools, map network drive, select the share location and select a drive letter to map it to, now in my computer this share will appear as a drive off a network. you can repeat this as required. Now install relax, set the ip of you xbox, create a new subfolder called movies and drag the new network drives into this subfolder so they are under the movies subfolder. now if you change config.xml as i said above to look in $ROOT$Movies on the ip of the pc which has relax and the mapped drives then it will be able to have a different location for each share folder. if this makes sense good, otherwise add me on msn or message me

#14 xboxmookie

xboxmookie

    X-S Enthusiast

  • Members
  • 15 posts

Posted 07 September 2003 - 03:48 PM

Works like a charm!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users